Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [eclipse-scripting-dev] Package names, refactoring


On Sun, Nov 3, 2013 at 11:39 AM, Christian Pontesegger <christian.pontesegger@xxxxxx> wrote:

I was thinking about the single extension point "org.eclipse.ease.language". Wouldn't it be much nicer to have "o.e.scripting.language" as it would be more natural? This would require plugin org.eclipse.ease to be renamed to o.e.scripting.

I'm not quite sure what you are suggesting for your extension here.

But your plugins should start with org.eclipse.ease and should all have the form org.eclipse.ease.<component> and by convention your extension points should then have the form org.eclipse.ease.<component>.<extensionName>.  So things for plugins you see names like org.eclipse.ease.core.*, org.eclipse.ease.ui.*, org.eclipse.ease.model.*, etc

The most common exception is if you have a few main extension points for your core plugins, in other projects I've seen them moved up one level, so org.eclipse.ease.<extensionName>


Paul Webster
Hi floor.  Make me a sammich! - GIR

Back to the top