[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [eclipse-pmc] Review of mass changes
- From: Lars Vogel <lars.vogel@xxxxxxxxxxx>
- Date: Wed, 19 Jun 2019 19:30:57 +0200
- Delivered-to: email@example.com
Small update from my side on the discussed changes...
I must admit that I'm getting tired of MANIFEST.MF version updates.
Seems to me that the main work of this it is update the versions in
the MANIFEST.MF instead of the real change.
As it is easy to recreate these changes, I plan to abandon most of the
changes which involves new version changes and might return to this
change after I recovered from Eclipse UI freezes and long Gerrit build
times for these version changes.
Best regards, Lars
On Wed, Jun 19, 2019 at 7:21 PM Eric Williams <ericwill@xxxxxxxxxx> wrote:
> On 6/19/19 12:47 PM, Mickael Istria wrote:
> > Hi,
> > My 2c below ;)
> > About !longChain.isEmpty() vs longChain.size() > 0, I favor the first
> > one because isEmpty() is theorically a O(1) operation while size() is a
> > O(n). Of course, most of smart enough implementations have this
> > optimized and make size() a O(1), but there is usually no guarantee it
> > is so. So size() is more expensive that isEmpty() and should be preferred.
> > About readability, I understand the concern and I would like to suggest
> > an alternative for that case: longChain.isEmpty() == false, which seems
> > to have the qualities requested by all parties.
> +1, this is a nice compromise!
> Eric Williams
> Software Engineer - Eclipse/SWT Team
> Red Hat
> eclipse-pmc mailing list
> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
Eclipse Platform project co-lead
CEO vogella GmbH
Haindaalwisch 17a, 22395 Hamburg
Amtsgericht Hamburg: HRB 127058
GeschÃftsfÃhrer: Lars Vogel, Jennifer Nerlich de Vogel
Fax (040) 5247 6322, Email: lars.vogel@xxxxxxxxxxx, Web: http://www.vogella.com