|[ecf-dev] Refactoring/Remodelling/Renaming Call API|
I started refactoring/remodelling the call API today and I would like to get your opinions with respect to an issue that has met some criticism from the community in the past.
The umbrella term “”Call API” seems inappropriate so I suggest we rename it to “Telephony API”. There are several reasons to support the renaming:
I look forward to you dropping your thoughts on this. In case of positive feedback, I will rename the packages from “org.eclipse.ecf.*” to “org.eclipse.ecf.telephony.*”. e.g. the “org.eclipse.ecf.call” package will become the “org.eclipse.ecf.telephony.call” package.
Back to the top