Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [dsdp-tm-dev] Do we still need J2SE 1.4 constraint?

Hi Johnson,
we definitely want to remain on J2SE-1.4 for Ganymede.
There is currently no compelling reason to require 1.5 -- this might be
revisited for next year's release.
The warning occurs in a development environment only, and tells
you that when you write new code and don't have 1.4 it might
happen by accident that you write code which would not run
on 1.4.
Just install an 1.4 JVM somewhere and use Prefernces > Java
> Execution Environments to let Eclipse know where it is.
Note that Eclipse just needs the 1.4 class libraries at development
time. You can still run or debug RSE with 1.5, 1.6 or any other
newer version.
Martin Oberhuber, Senior Member of Technical Staff, Wind River
Target Management Project Lead, DSDP PMC Member

From: dsdp-tm-dev-bounces@xxxxxxxxxxx [mailto:dsdp-tm-dev-bounces@xxxxxxxxxxx] On Behalf Of Johnson Ma
Sent: Mittwoch, 13. Februar 2008 07:01
To: dsdp-tm-dev@xxxxxxxxxxx
Subject: [dsdp-tm-dev] Do we still need J2SE 1.4 constraint?

Hi All,

I got some warnings after check out TM plugins from CVS.

"Build path specifies execution environment J2SE-1.4. There are no JREs in the workspace strictly compatible with this environment"

This is caused by the constraints in all MANIFEST.MF files :
Bundle-RequiredExecutionEnvironment: J2SE-1.4

From CVS history, this limitation was added late 2006.

i am wondering that do we still have this limitation?

Giving the fact that most java developers are using jdk5 at least, and jdk7.0 is on the road.



Johnson Ma
MTS at WindRiver
Eclipse Committer for STP project
User Experience Matters

Back to the top