Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [dsdp-tm-dev] Installing 2.0M5

Hi Travis,

TM 2.0M5 REQUIRES Eclipse 3.3M5, at least for installing through
the Update Manager.

Sorry for not being clear about that.

org.eclipse.cvs is a new feature that was introduced with Eclipse 
Platform 3.3M5. It's just a change in bundling, but in order to 
properly advertise dependencies on the Europa coordinated update 
site, we had to specify it that way.

By installing the packages from our download site rather than the
update site, you worked around the update manager's feature 
dependency, and that's fine because the plugin dependency still
requires com.jcraft.jsch only. So your installation should be
good to go for normal work, but most probably the update manager
will deny any more updates for you because you created something
that looks like an incorrect configuration for it.

You can continue working with your current configuration, but 
before using the update manager next time, you'll have to update
to Eclipse Platform 3.3M5.

Martin Oberhuber
Wind River Systems, Inc.
Target Management Project Lead, DSDP PMC Member 
> -----Original Message-----
> From: dsdp-tm-dev-bounces@xxxxxxxxxxx 
> [mailto:dsdp-tm-dev-bounces@xxxxxxxxxxx] On Behalf Of Travis Stratman
> Sent: Monday, February 26, 2007 11:19 PM
> To: Target Management developer discussions
> Subject: Re: [dsdp-tm-dev] Installing 2.0M5
> Downloading the package from the tm site and manually 
> unpacking into the
> eclipse install seemed to fix this issue.  I believe that
> org.eclipse.cvs needs to be changed to on the
> dependencies for the project for the update manager.
> Thanks,
> Travis
> On Mon, 2007-02-26 at 15:24 -0600, Travis Stratman wrote:
> > Hello,
> > 
> > I have been trying to install 2.0M5 and have encountered an 
> issue that
> > I'm not sure how to resolve.  When I try to install the RSE SSH
> > services, I get an error:
> > 
> > RSE SSH Services (2.0.0.v20070223------3YIAAcAIIH) requires feature
> > "org.eclipse.cvs (1.0.0)", or later version.
> > 
> > This worked fine with the previous release.  I tried searching for
> > org.eclipse.cvs on all of the standard eclipse update sites 
> and could
> > not find it.  I attempted to install through both Eclipse 3.2.2 and
> > 3.3M4 with the same results.  In looking at the 
> dependencies of the last
> > release, I noticed that was required.  Should
> > org.eclipse.cvs be, or am I missing something?
> > Where can I find this plugin?
> > 
> > Thanks in advance,
> > 
> > Travis
> > 
> > _______________________________________________
> > dsdp-tm-dev mailing list
> > dsdp-tm-dev@xxxxxxxxxxx
> >
> _______________________________________________
> dsdp-tm-dev mailing list
> dsdp-tm-dev@xxxxxxxxxxx

Back to the top