[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] Update site time outs

Ed,

I agree with your assessment below.  I've opened a number of bugs against p2 over the years but there appear to be few resources to help address the issues (this is not a complaint, just an observation).

Indeed, p2 is very "chatty" with download.eclipse.org and I don't think it needs to be.

Denis





On 05/03/15 02:53 AM, Ed Merks wrote:
Camille,

The download server has been maxed out all week with HTTP connections at between 9,000 to 12,000 for download1, which I assume is the primary server for http:/download.eclipse.org:

https://dev.eclipse.org/committers/help/status.php

Things like http://download.eclipse.org/releases/luna/201501121000/content.jar were taking often more than 4 minutes to download.

Today it's finally at a more reasonable level at less than 3,000 when I used it early in the morning in Europe and I am able to work effectively again. 

Some of these problems seem to be to be fundamentally p2 problems.  Eike and I looked very closely at the underlying infrastructure as part of the Oomph work and even added offline support for Oomph as a layer on top, but p2 itself has a habit of downloading content and artifact files (not to mention the artifacts themselves when not using bundle pool) over and over again.   Also p2 tries many combinations for different potential update site configurations many of which yield 404.  In the end, it's very annoying to wait for the same things to download again and again and when large numbers of users are all doing that at the same time, failing, and trying again, it becomes a serious server problem. 

Regards,
Ed


On 04/03/2015 4:33 PM, LETAVERNIER Camille wrote:

Hi,


We’ve received several notifications [1] from users who encounter a lot of “Read time out” when they are trying to install/update some components from the simrel (/releases/luna) update site. It seems that it is a general issue (not specific to Papyrus). The same thing happens on the mars simrel update site (/releases/mars)

 

Are there some known server/performances issues? Maybe related to the recent SR2 release? Did anyone else run into these issues?

 

[1] https://www.eclipse.org/forums/index.php/t/1025771/

 

Camille



_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev



_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev