Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[cross-project-issues-dev] Feature names

In Bug 322188 [1] Chris is addressing the package comparison page. On that page, we're displaying a subset of the features included in the page in table form (Chris has added some _javascript_ to tune the appearance).

We take the name of the features he's showing from the feature in the Kepler repository (extracted a few days ago). Here's the current list:

CVS Client
Data Tools Platform Model Base
Graphical Editing Framework GEF
Java Development Tools
Mylyn Task List
Java EE Developer Tools
XML Editors and Tools
Remote System Explorer End-User Runtime
Dali Java Persistence Tools - EclipseLink Common
Plug-in Development Environment
Data Tools Platform Intro
C/C++ Development Tools
BIRT Framework
Parallel Tools Platform (PTP) End-User Runtime
RAP Tools
WindowBuilder Core
m2e - Maven Integration for Eclipse
Code Recommenders Developer Tools
Graphiti (Incubation)

These same feature names will be used on the package description pages. I'm going to recommend that we drop "RCP" from the list, since I think that really means "Platform", and that should be included in all packages. We may have to help Chris select better features to include on the list. I recommend that we take that discussion to the bug.

Since people will be using these to select a package, I think it's in our best interests for these names to have meaning for a target audience that might not understand (or care about) our project structure. I believe that this is consistent with the intent of feature names. Correct me if I'm wrong.

Please spend a few minutes to look at your project's feature names to ensure consistency. I'd like to see "End-User Runtime" dropped from the feature names, for example, as I think it's meaningless. If there are better features to be included in the list, please say so. I'm thinking for example, that it might be more meaningful to include "SWT Designer" and "Swing Designer" instead of "WindowBuilder Core". Perhaps "EGit" should be "Git Client". Thoughts?

I'm inclined to just drop features that are only project names and these aren't generally meaningful to the target audience. Thoughts?


Wayne Beaton
Director of Open Source Projects, The Eclipse Foundation
Learn about Eclipse Projects
          France 2013

Back to the top