[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] Heads up ... org.junit4 is gone from M6

On 03/08/2013 11:08 AM, Wenz, Michael wrote:

David,

 

this indeed came at the right time, I just stumbled over that…

 

Unfortunatly I was not yet able to resolve that. The reason is that we (Graphiti) use SWTBot for our UI tests, and SWTBot test infrastructure has a dependency on org.junit4 (we use it via our GEF tests but as it part of the swtbot.eclipse dependencies this should also affect planin Eclipse UI tests):

Org.eclipse.swtbot.eclipse.gef

                Org.eclipse.swtbot.eclipse

                               Org.eclipse.swtbot.go

                                               Org.junit4

 

Is anybody else having this issue? Do I overlook anything, especially how to resolve this?

See https://bugs.eclipse.org/bugs/show_bug.cgi?id=401716
This has already been resolved and latest SWTBot snapshot builds don't depend on org.junit4 any longer. Next release should happen later this month.

You only have a dependency to org.junit4 for your tests, it's not a blocker for simultaneous release as long as you don't depend on it in the features you contribute to simultaneous release. What you could do - unti SWTBot 2.1.0 gets released-, if you're using Tycho, is just to add to your test pom.xml a repository (such as Tycho) containing this org.junit4 bundle so it will use it for resolution, only for tests.

HTH
--
Mickael Istria
Eclipse developer at JBoss, by Red Hat
My blog - My Tweets