Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cdt-dev] Answering a poor post

I don’t think the form is moderated.  At least as a committer I was always able to post so you should too.

What happens that makes you feel it is moderated?

 

From: cdt-dev-bounces@xxxxxxxxxxx [mailto:cdt-dev-bounces@xxxxxxxxxxx] On Behalf Of Corbat Thomas
Sent: Wednesday, June 18, 2014 2:07 AM
To: CDT General developers list.
Subject: Re: [cdt-dev] Answering a poor post

 

I shared the three (very simple) steps I always perform to setup my C++ development environment (with MinGW). This should be easily reproducible for anyone, when the moderated post comes online…

 

Regards

Thomas

 

From: cdt-dev-bounces@xxxxxxxxxxx [mailto:cdt-dev-bounces@xxxxxxxxxxx] On Behalf Of Doug Schaefer
Sent: Dienstag, 17. Juni 2014 20:52
To: CDT General developers list.
Subject: Re: [cdt-dev] Answering a poor post

 

My main issue with Cygwin is that the cygwin runtime has a pretty restrictive license. You can only do open source works with it.

    http://cygwin.com/licensing.html

At least Qt made an LGPL version that provided more freedom for the developer. And enabling an LGPL Qt install with CDT would also be something I'd love to have with the Eclipse C/C++ IDE.

Doug.


From: cdt-dev-bounces@xxxxxxxxxxx [cdt-dev-bounces@xxxxxxxxxxx] on behalf of Francis ANDRE [francis.andre.kampbell@xxxxxxxxx]
Sent: Tuesday, June 17, 2014 12:23 PM
To: cdt-dev@xxxxxxxxxxx
Subject: Re: [cdt-dev] Answering a poor post

All

This guy just did not install the gcc compiler tools from Cygwin...Installing the gnu tools is an optional feature of the Cygwin installer... so no one can help him in this desperate case except to tell him to install the gnu gcc tool set ...

By the way, I confirm that -- on a W7/x86_64/Cygwin platform -- even the provided HelloWorld sample does not work... see this issue https://bugs.eclipse.org/bugs/show_bug.cgi?id=437090 and this one https://bugs.eclipse.org/bugs/show_bug.cgi?id=117013 is always pending

Letting those two issues opened won't help in getting beginner CDT's  user happy with CDT on a W7/x86_64/Cygwin platform (I am talking only of Cygwin, because I never tested MinGW, one problem at a time..)

FA

 

Le 17/06/2014 16:30, Marc Khouzam a √©crit :

I saw this a little while ago.  It sounds un-justified to me but since I don’t use Windows I can’t really answer.

I know many of you are using Cygwin or MinGW with CDT.

My guess is that this user didn’t configure things right.

Can someone who uses CDT on Windows confirm (nicely J) to him/her (and everyone else that might fall on this post)

that things do work and that the user probably is facing poor configuration of his toolchain?

 

We’re going to get some frustrated users even if it is not justified, but I don’t like to see these posts

go un-answered as if they were correct.

 

Thanks

 

Marc

 

 

From: forums-noreply@xxxxxxxxxxx [mailto:forums-noreply@xxxxxxxxxxx]
Sent: Thursday, June 05, 2014 9:30 AM
To: Marc Khouzam
Subject: New topic in forum C / C++ IDE (CDT), called cdt is the worst thing i have seen at least on windows, by dd aa

 

Subject: cdt is the worst thing i have seen at least on windows

Author: dd aa

Date: Thu, 05 June 2014 09:27

sorry to say this but,
after days of working on windows 7 64bit with cygwin and mingw,
i concluded that cdt on windows eclipse is the worst thing on development.

it really doesn's work.

if someone struggling with errors like "eclipse Program "gcc" not found in PATH",
forget about it, and install the visual studio of microsoft.

as of last update's of cygwin and mingw, cdt isn't working, and nobody did'nt found how to do it.




[ Reply ][ Quote ][ View Topic/Message ][ Unsubscribe from this forum ]

 




_______________________________________________
cdt-dev mailing list
cdt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/cdt-dev

 


Back to the top