Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Titan » Installation problems on Window 10 Cygwin(Install problems)
Installation problems on Window 10 Cygwin [message #1827466] Fri, 15 May 2020 03:51 Go to next message
Didi He is currently offline Didi HeFriend
Messages: 7
Registered: May 2020
Junior Member
Hi,

I install the TITAN on Win10.
The problem happens in compile TITAN.When I type in 'make -dep',there are some fatal errors. Then I type make install,there are errors .Error1 and Error 2.
Pls see the attachment.
Could someone help me ?
Re: Installation problems on Window 10 Cygwin [message #1827470 is a reply to message #1827466] Fri, 15 May 2020 05:54 Go to previous messageGo to next message
Jeno Attila Balasko is currently offline Jeno Attila BalaskoFriend
Messages: 78
Registered: September 2013
Location: Budapest, Hungary
Member

Hi,
as you can read fom the end of the log, you shall install program "expect". Start cygwin installation program and do not change anything else but search "expect", choose it and install.
This is answer for make install. The "make dep" is not clearly documented in this conversation.
Hopefully this helps.
Best regards
Jenő Balaskó, Titan Team
Re: Installation problems on Window 10 Cygwin [message #1827471 is a reply to message #1827466] Fri, 15 May 2020 05:55 Go to previous messageGo to next message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 1063
Registered: January 2015
Senior Member
Hi Didi,

did you follow the installation/configuration flow as exemplified in the tutorial video?

TITAN installation tutorial video for Windows with compiling on Cygwin.(Installation tutorial for the TITAN TTCN-3 toolset on Windows with compiling on Cygwin.)
https://www.eclipse.org/forums/index.php/t/1103718/

BR

Elemer
Re: Installation problems on Window 10 Cygwin [message #1827525 is a reply to message #1827470] Sun, 17 May 2020 10:09 Go to previous messageGo to next message
Didi He is currently offline Didi HeFriend
Messages: 7
Registered: May 2020
Junior Member
Hi Jeno,

Thanks for your answer!

I choose the "tcl expect' when install cywin.But there are still errors in the step"make install"see the attachment below.

BR,
Didi
Re: Installation problems on Window 10 Cygwin [message #1827529 is a reply to message #1827525] Sun, 17 May 2020 15:42 Go to previous messageGo to next message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 1063
Registered: January 2015
Senior Member
Hi Didi,

if you don't want to use the Eclipse IDE, and you intend to use Titan in command line mode only,

you are probably better off if you install say a Ubuntu in Windows Subsystem For Linux, and install/build Titan under that.
Even better , you could use a Linux machine if you are not tied to Windows.

BR

Elemer
Re: Installation problems on Window 10 Cygwin [message #1827537 is a reply to message #1827529] Mon, 18 May 2020 00:29 Go to previous messageGo to next message
Didi He is currently offline Didi HeFriend
Messages: 7
Registered: May 2020
Junior Member
Hi Elemer ,

Thanks for your answer!

I am trying to install titan and use it in Win10,also I want to use Eclipse IDE but the process is not going well..

BR
Didi
Re: Installation problems on Window 10 Cygwin [message #1827557 is a reply to message #1827537] Mon, 18 May 2020 07:59 Go to previous message
Kristof Szabados is currently offline Kristof SzabadosFriend
Messages: 54
Registered: July 2015
Member
Hi Didi,

Could you please check the contents of your Install directory?
In particular the c:\cygwin64\home\hover\git\titan.core\Install\include\RT1 forlder.
I can not read the Chinese characters, but maybe the folder is read only, or looking at it might help us further in some way.

Also please note that when using cygwin one can copy out the texts too.
In my case I just need to select the text in the terminal window, right click on the toolbar of the terminal window and select edit/copy ... after this the text can be copy pasted.
(or at least it works with ascii characters on my machine)

Br
Kristof
Previous Topic:Cannot make Demo Example from Titan
Next Topic:TITAN installation tutorial video for Windows with compiling on Cygwin.
Goto Forum:
  


Current Time: Fri Jul 10 10:48:37 GMT 2020

Powered by FUDForum. Page generated in 0.01607 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top