Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Nebula » Problems running Fortran code(Eclipse-photran fails to run parallel fortran 90 code)
icon11.gif  Problems running Fortran code [message #1759417] Tue, 11 April 2017 13:56
Basit Khan is currently offline Basit KhanFriend
Messages: 1
Registered: April 2017
Junior Member
Hi there,

I am a newbie to both eclipse and this forum. I am trying to use an LES model named PALM with eclipse-photron

The main objective is use the debugging features provided in eclipse. I Installed eclipse-photran on my 12 core ubuntu 14.04 machine with intel Xeon processors, and configured eclipse for palm by following instructions on PALM website.

Eclipse compiled PALM successfully, however, it run the parallel code only through Run --> External Tools --> External Tool Configuration --> Run.

If i try to run my prallel program by pressing the run button, i get the following error.

** MRUN 2.1 Rev: 1945 $
will be executed. Please wait ...

+++ configuration file:
.mrun.config
does not exist

+++ MRUN killed

However, the .mrun.config file is there in ${workspace_loc}.

If i try to run my code in debugger mode, i get the following error:

Error stopping at palm.
Reason: Target request failed: No symbol table is loaded. Use the "file" command continue?

<terminated> chem_noncyclic [Fortran Local Application]gdb
"/home/khan-b/palm/current_version/trunk/SCRIPTS/mrun": not in executable format: File format not recognized
.gdbinit: No such file or directory.


I wonder if somebody could help me fixing this.

Thanks in advance for any suggestion, advise and help.

Cheers,
Basit





Re: Problems running Fortran code [message #1759428 is a reply to message #1759417] Tue, 11 April 2017 08:13 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
You're asking in the wrong forum.
The Photran project uses a mailing list for community discussions. See https://www.eclipse.org/photran/mailinglists.php
Previous Topic:Big data grid memory usage
Next Topic:CDateTime shows analog clock regardless of CLOCK_DISCRETE setting
Goto Forum:
  


Current Time: Fri Sep 21 09:27:30 GMT 2018

Powered by FUDForum. Page generated in 0.02804 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top