Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » 4DIAC-IDE 1.8 M1
4DIAC-IDE 1.8 M1 [message #1718604] Mon, 28 December 2015 09:09 Go to next message
Ole Carlsen is currently offline Ole CarlsenFriend
Messages: 16
Registered: September 2015
Junior Member
Anywhere to find how 1.8 differs from 1.7? Some change-log, wiki or the like?

I'm trying to figure out where I will link to the default FORTE and FBRT for local testing. In version 1.7 there was 4DIAC preference but it seems to be gone now? And Deployment what happen to this? Not needed anymore?

Runing 4DIAC-IDE_1.8M1_linux.gtk.x86_64 but I start to think I have overlooked something as nobody have raised this as issues/questions.
Re: 4DIAC-IDE 1.8 M1 [message #1718610 is a reply to message #1718604] Mon, 28 December 2015 09:50 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 523
Registered: January 2014
Senior Member
So far we don't have a full changelog. A summary is given in this news post [1].

However the features you are mentioning should still be part of 4DIAC. When thing that could be a reason for the problem is that 4DIAC 1.8 now requires Java 1.8 to run.

Could you post the .log file from your workspace's .metadata directoy?


[1] https://www.eclipse.org/4diac/en_news.php#en_news_20151204
Re: 4DIAC-IDE 1.8 M1 [message #1718639 is a reply to message #1718610] Mon, 28 December 2015 15:19 Go to previous messageGo to next message
Ole Carlsen is currently offline Ole CarlsenFriend
Messages: 16
Registered: September 2015
Junior Member
No need to post the log, I just installed JAVA 8 and it seems to be running again. I hadn't thought of that being the reason but should have guessed hence 1.5, 1.6, 1.7 and now 1.8 Smile
Re: 4DIAC-IDE 1.8 M1 [message #1718690 is a reply to message #1718639] Tue, 29 December 2015 09:24 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 523
Registered: January 2014
Senior Member
We should add this more prominently to the release notes. 4DIAC itself is not making to much use of Java 8 so far. But several of the components used are. Especially we plan to move to Eclipse Mars.2 with the final 1.8 release and Mars requires also Java 8.
Re: 4DIAC-IDE 1.8 M1 [message #1718754 is a reply to message #1718690] Tue, 29 December 2015 19:30 Go to previous message
Ole Carlsen is currently offline Ole CarlsenFriend
Messages: 16
Registered: September 2015
Junior Member
If the IDE would check during startup and give the information if JAVA x is not available so the user knows, would be a help, at least it would have been for me. Normally I would run the latest JAVA version but as I only have it installed for 4DIAC and the last thing I read was JAVA 8 was not a good idea to use.

Another thing is the default path for FBRT and FORTE which are pointing at ..\Training\ if they always pointed at the relative path to where my IDE is installed then I just needed to take action if I use a own build version (this should probably go to bugs/suggestion instead)
Previous Topic:Building FORTE on RaspberryPi 2 B using MacBook Pro
Next Topic:M1 - Platform support
Goto Forum:
  


Current Time: Sun May 20 16:10:22 GMT 2018

Powered by FUDForum. Page generated in 0.01454 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top