Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Missing dependency on snapshot site
Missing dependency on snapshot site [message #734121] Thu, 06 October 2011 18:24 Go to next message
Carsten Reckord is currently offline Carsten ReckordFriend
Messages: 139
Registered: July 2009
Senior Member
Hi folks,

Just a heads-up from a recent post in the Egit forum (here -
http://www.eclipse.org/forums/index.php/t/244567/):

It seems that the latest weekly snapshot build is missing a bundle providing
the required com.sun.syndication.feed package, leading to

Cannot complete the install because one or more required items could not be
found.
Software being installed: EGit Mylyn 1.1.0.201109151100-r
(org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r)
Missing requirement: Mylyn Tasks Core 3.7.0.I20110928-1200
(org.eclipse.mylyn.tasks.core 3.7.0.I20110928-1200) requires 'package
com.sun.syndication.feed 0.9.0' but it could not be found
Cannot satisfy dependency:
From: EGit Mylyn 1.1.0.201109151100-r
(org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r)
To: org.eclipse.egit.mylyn.ui [1.1.0.201109151100-r]
Cannot satisfy dependency:
From: EGit Mylyn UI 1.1.0.201109151100-r (org.eclipse.egit.mylyn.ui
1.1.0.201109151100-r)
To: bundle org.eclipse.mylyn.tasks.core [3.0.0,4.0.0)
Re: Missing dependency on snapshot site [message #734291 is a reply to message #734121] Fri, 07 October 2011 11:53 Go to previous messageGo to next message
Manuel Doninger is currently offline Manuel DoningerFriend
Messages: 119
Registered: October 2010
Senior Member
This bundle is in the Eclipse Orbit repository. I don't know, if the Orbit repository can automatically be added, if Mylyn is installed. Manually adding the Orbit repository and then installing Mylyn should definitely help.
Re: Missing dependency on snapshot site [message #735054 is a reply to message #734291] Mon, 10 October 2011 19:27 Go to previous messageGo to next message
Le Snelson is currently offline Le SnelsonFriend
Messages: 2
Registered: October 2011
Junior Member
And the Orbit repo would be ... ?
Re: Missing dependency on snapshot site [message #735077 is a reply to message #735054] Mon, 10 October 2011 21:11 Go to previous messageGo to next message
Carsten Reckord is currently offline Carsten ReckordFriend
Messages: 139
Registered: July 2009
Senior Member
On 10.10.2011 21:27, Le Snelson wrote:
> And the Orbit repo would be ... ?
Current Orbit site is
http://download.eclipse.org/tools/orbit/downloads/drops/R20110523182458/repository/

See http://download.eclipse.org/tools/orbit/downloads/ for an uptodate list
of Orbit builds and site URLs
Re: Missing dependency on snapshot site [message #752175 is a reply to message #735077] Wed, 26 October 2011 09:50 Go to previous messageGo to next message
Bart Bubak is currently offline Bart BubakFriend
Messages: 3
Registered: October 2011
Junior Member
Hi,
I have the same problem:
Cannot complete the install because one or more required items could not be found.
  Software being installed: EGit Mylyn 1.1.0.201109151100-r (org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r)
  Missing requirement: EGit Mylyn 1.1.0.201109151100-r (org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r) requires 'org.eclipse.mylyn.team_feature.feature.group 3.5.0' but it could not be found


Manually adding current Orbit repository also didn't help.
Do you have any idea how solve this problem?

Eclipse 3.7.0
Ubuntu 11.10
Re: Missing dependency on snapshot site [message #752446 is a reply to message #752175] Wed, 26 October 2011 11:50 Go to previous messageGo to next message
Manuel Doninger is currently offline Manuel DoningerFriend
Messages: 119
Registered: October 2010
Senior Member
This is another problem, because in your case the Team feature couldn't be found. Do you use an Eclipse package downloaded from eclipse.org?

[Updated on: Wed, 26 October 2011 11:51]

Report message to a moderator

Re: Missing dependency on snapshot site [message #752523 is a reply to message #752446] Wed, 26 October 2011 12:23 Go to previous messageGo to next message
Bart Bubak is currently offline Bart BubakFriend
Messages: 3
Registered: October 2011
Junior Member
No i get it from Ubuntu repositories.

Downloaded from eclipse.org (linux 64bit)
Result after manually added Orbit repos:
Cannot complete the install because one or more required items could not be found.
  Software being installed: EGit Mylyn 1.1.0.201109151100-r (org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r)
  Missing requirement: EGit Mylyn UI 1.1.0.201109151100-r (org.eclipse.egit.mylyn.ui 1.1.0.201109151100-r) requires 'bundle org.eclipse.mylyn.monitor.core [3.0.0,4.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: EGit Mylyn 1.1.0.201109151100-r (org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r)
    To: org.eclipse.egit.mylyn.ui [1.1.0.201109151100-r]

[Updated on: Wed, 26 October 2011 12:39]

Report message to a moderator

Re: Missing dependency on snapshot site [message #752545 is a reply to message #752175] Wed, 26 October 2011 12:32 Go to previous messageGo to next message
Steffen Pingel is currently offline Steffen PingelFriend
Messages: 706
Registered: July 2009
Senior Member
You need to either enable the Mylyn or Indigo update site and select
"Contact all update sites..." in the Install New Software dialog. The Mylyn
update site is located here:
http://download.eclipse.org/mylyn/releases/latest

Steffen


Bart Bubak wrote:

> Hi,
> I have the same problem:
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: EGit Mylyn 1.1.0.201109151100-r
> (org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r) Missing
> requirement: EGit Mylyn 1.1.0.201109151100-r
> (org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r) requires
> 'org.eclipse.mylyn.team_feature.feature.group 3.5.0' but it could not be
> found
>
> Manually adding current Orbit repository also didn't help.
> Do you have any idea how solve this problem?
>
> Eclipse 3.7.0
> Ubuntu 11.10

--
Steffen Pingel
Committer, http://eclipse.org/mylyn
Senior Developer, http://tasktop.com
Re: Missing dependency on snapshot site [message #752575 is a reply to message #752545] Wed, 26 October 2011 12:46 Go to previous message
Bart Bubak is currently offline Bart BubakFriend
Messages: 3
Registered: October 2011
Junior Member
Steffen Pingel wrote on Wed, 26 October 2011 08:32
You need to either enable the Mylyn or Indigo update site and select
"Contact all update sites..." in the Install New Software dialog. The Mylyn
update site is located here:

Steffen



Thanks a lot, this repo solve my problem.
Previous Topic:API to access Task Categories / Queries?
Next Topic:[Wikitext] Asciidoc support?
Goto Forum:
  


Current Time: Sat Dec 20 12:25:13 GMT 2014

Powered by FUDForum. Page generated in 0.01962 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software