Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Cannot install EGit 1.1
Cannot install EGit 1.1 [message #733576] Wed, 05 October 2011 05:36 Go to next message
ovangle is currently offline ovangleFriend
Messages: 2
Registered: October 2011
Junior Member
Hey,

I'm having some trouble installing Egit 1.1 on Eclipse 3.7.0. When I try to install it gives me the error message:

Cannot complete the install because one or more required items could not be found.
  Software being installed: EGit Mylyn 1.1.0.201109151100-r (org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r)
  Missing requirement: Mylyn Tasks Core 3.7.0.I20110928-1200 (org.eclipse.mylyn.tasks.core 3.7.0.I20110928-1200) requires 'package com.sun.syndication.feed 0.9.0' but it could not be found
  Cannot satisfy dependency:
    From: EGit Mylyn 1.1.0.201109151100-r (org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r)
    To: org.eclipse.egit.mylyn.ui [1.1.0.201109151100-r]
  Cannot satisfy dependency:
    From: EGit Mylyn UI 1.1.0.201109151100-r (org.eclipse.egit.mylyn.ui 1.1.0.201109151100-r)
    To: bundle org.eclipse.mylyn.tasks.core [3.0.0,4.0.0)


What am I missing here?
Re: Cannot install EGit 1.1 [message #733940 is a reply to message #733576] Thu, 06 October 2011 04:15 Go to previous messageGo to next message
ovangle is currently offline ovangleFriend
Messages: 2
Registered: October 2011
Junior Member
No-one has any idea? I mean, the error message seems direct enough -- the package com.sun.syndication.feed 0.9.0 has to be added somewhere, but I don't know where to get it from, nor why I should need to install it separately -- EGit installed without a second thought on Helios.

Also, I should point out that there is no CVS available for me either in Eclipse, but the project that I'm supposed to be committing to (and am having to do so from the terminal atm) is managed with git, so it doesn't bother me too much.
Re: Cannot install EGit 1.1 [message #734009 is a reply to message #733576] Thu, 06 October 2011 11:03 Go to previous messageGo to next message
R Shapiro is currently offline R ShapiroFriend
Messages: 386
Registered: June 2011
Senior Member
You probably want to be at 3.7.1, not 3.7.0. Get the SR1 update.
Re: Cannot install EGit 1.1 [message #734105 is a reply to message #733576] Thu, 06 October 2011 17:12 Go to previous messageGo to next message
Robin Rosenberg is currently offline Robin RosenbergFriend
Messages: 332
Registered: July 2009
Senior Member
ovangle skrev 2011-10-05 07.36:
> Hey,
>
> I'm having some trouble installing Egit 1.1 on Eclipse 3.7.0. When I try
> to install it gives me the error message:
>
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: EGit Mylyn 1.1.0.201109151100-r
> (org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r)
> Missing requirement: Mylyn Tasks Core 3.7.0.I20110928-1200
> (org.eclipse.mylyn.tasks.core 3.7.0.I20110928-1200) requires 'package
> com.sun.syndication.feed 0.9.0' but it could not be found
> Cannot satisfy dependency:
> From: EGit Mylyn 1.1.0.201109151100-r
> (org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r)
> To: org.eclipse.egit.mylyn.ui [1.1.0.201109151100-r]
> Cannot satisfy dependency:
> From: EGit Mylyn UI 1.1.0.201109151100-r (org.eclipse.egit.mylyn.ui
> 1.1.0.201109151100-r)
> To: bundle org.eclipse.mylyn.tasks.core [3.0.0,4.0.0)

Those errors are hard to grok, but it might mean that you do not have
Mylyn installed OR you have incompatble version. Do not include the EGit
Mylyn feature in your installation.

-- robin
Re: Cannot install EGit 1.1 [message #734119 is a reply to message #733576] Thu, 06 October 2011 18:16 Go to previous messageGo to next message
Carsten Reckord is currently offline Carsten ReckordFriend
Messages: 139
Registered: July 2009
Senior Member
On 05.10.2011 07:36, ovangle wrote:
> Hey,
>
> I'm having some trouble installing Egit 1.1 on Eclipse 3.7.0. When I try to install it gives me the error message:
>
> Cannot complete the install because one or more required items could not be found.
> Software being installed: EGit Mylyn 1.1.0.201109151100-r (org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r)
> Missing requirement: Mylyn Tasks Core 3.7.0.I20110928-1200 (org.eclipse.mylyn.tasks.core 3.7.0.I20110928-1200) requires 'package com.sun.syndication.feed 0.9.0' but it could not be found
> Cannot satisfy dependency:
> From: EGit Mylyn 1.1.0.201109151100-r (org.eclipse.egit.mylyn.feature.group 1.1.0.201109151100-r)
> To: org.eclipse.egit.mylyn.ui [1.1.0.201109151100-r]
> Cannot satisfy dependency:
> From: EGit Mylyn UI 1.1.0.201109151100-r (org.eclipse.egit.mylyn.ui 1.1.0.201109151100-r)
> To: bundle org.eclipse.mylyn.tasks.core [3.0.0,4.0.0)
>
> What am I missing here?

The culprit seems to be the latest Mylyn snapshot site that you have your
Eclipse pointed to. Try disabling
http://download.eclipse.org/mylyn/snapshots/weekly in your list of available
sites and add or enable http://download.eclipse.org/mylyn/releases/latest
instead.

The Mylyn 3.7 snapshot build apparently misses a bundle that satisfies the
new dependency to com.sun.syndication.feed...
Re: Cannot install EGit 1.1 [message #734292 is a reply to message #734119] Fri, 07 October 2011 11:54 Go to previous message
Manuel Doninger is currently offline Manuel DoningerFriend
Messages: 119
Registered: October 2010
Senior Member
As a workaround you can add manually the Eclipse Orbit update site (http://download.eclipse.org/tools/orbit/downloads/drops/R20110523182458/repository/) to your software sites, and then try again the EGit installation (com.sun.syndication is in the Orbit site).
Previous Topic:HTTPProxy failure using ssh protocol?
Next Topic:pull from bundle file
Goto Forum:
  


Current Time: Wed Nov 26 23:26:42 GMT 2014

Powered by FUDForum. Page generated in 0.09503 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software