[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[wtp-dev] WTP depends on CVS plugins?

I just discovered that org.eclipse.jst.servlet.ui depends on CVS plugins.

 

http://git.eclipse.org/c/jeetools/webtools.javaee.git/tree/plugins/org.eclipse.jst.servlet.ui/META-INF/MANIFEST.MF

 

org.eclipse.team.cvs.core;bundle-version="[3.3.0,5.0.0)",

org.eclipse.team.cvs.ui;bundle-version="[3.3.0,5.0.0)",

 

This makes it impossible to create an install with WTP, but no CVS plugins. Since CVS is becoming progressively less relevant, this requirement is progressively becoming more important.

 

Before I dive in to figure out why this is so, does anyone know why?

 

Thanks,

 

- Konstantin