Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[wtp-dev] Eclipse 3.1 and J2SE 1.5 (1.4 compatability mode) support

To: wtp-dev


For the last few weeks I've tried to integrate Pollinate project to run against WPT.

I've succeeded partially: I was able to create simple Pollinate Web module against WTP N20041101 build and actually run the sample Beehive application on Tomcat 5.0.27. The reason why I tried N20041101 first is that I can't develop against latest build because of the recent bug:
but this is not my main concern here.

As you may know Pollinate target operating environment is Eclipse 3.1 and J2SE 1.5. And from WTP Project 1.0 Plan I know that your plan is to support mainly 1.4 for
the first 1.0 release.

My main question is can you improve your support up to J2SE 1.5 in 1.4 compatibility

The reason I'm asking is that there are some small library level incompatibilities between Sun's 1.5 and 1.4 (e.g. in org.w3c.dom.Node interface). So as soon as you'll get latest CVS trunk in 3.1 under 1.5, you will notice the problems. This problem can be solved if you'll support "library" level compatibility with 1.5. Most of the core Java 1.5 features
are backward compatible.

Another way to solve this is to put correct version of XML under 1.5 endorsed dir to
override the default one. But this is different story.

Another thing is: many of WTP projects have their Java compiler settings to workspace default. In my workspace it is 1.5, so many languages problems (e.g. using enum, which is a reserved word in 1.5) can be avoided if project will explicitly set the 1.4 compliance

Alexander Smirnoff
Pollinate Project.

Back to the top