Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[tycho-user] Issue with Tycho > 0.22.0


I'm trying to update the build of an Eclipse RCP project which is still using Tycho 0.21.0 to Tycho 1.7.0.
With Tycho versions greater than 0.22.0 the build doesn't work anymore and I don't understand how it needs to be configured properly.

I have created a sample project which shows the issue:

The project consists of
- a p2 repository which contains the same plugin (org.apache.activemq.activemq-core) with two different versions (5.2.0 and 5.4.0)
- a feature which contains this plugin but not in the latest version
- a product configuration which uses this feature (but no explicit plugins) and a configuration for the plugin of the feature

Using Tycho version 0.22.0 the build still works fine. Using Tycho > 0.22.0 the build fails:

Cannot complete the install because one or more required items could not be found.
        Software being installed: Sample Product 1.0.0 (com.test.sample.product 1.0.0)
        Missing requirement: toolingwin32.win32.x86_64org.apache.activemq.activemq-core 1.0.0 requires 'osgi.bundle; org.apache.activemq.activemq-core 5.4.0' but it could not be found
        Cannot satisfy dependency:
                From: Sample Product 1.0.0 (com.test.sample.product 1.0.0)
                To: org.eclipse.equinox.p2.iu; toolingcom.test.sample.product.configuration [1.0.0,1.0.0]
        Cannot satisfy dependency:
                From: toolingcom.test.sample.product.configuration 1.0.0
                To: org.eclipse.equinox.p2.iu; toolingwin32.win32.x86_64org.apache.activemq.activemq-core [1.0.0,1.0.0]

If you remove the configuration for the plugin in sample.product the build works also with Tycho > 0.22.0 again.

How do I need to configure the product with Tycho > 0.22.0 so that I can keep the plugin configuration and the correct plugin version is being used during the build?


Back to the top