Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-user] set-version not updating feature.xml

Yeah but https://www.eclipse.org/tycho/sitedocs/tycho-release/tycho-versions-plugin/plugin-info.html claims to update the dependencies as well such as feature.xml files, yet it didn't - any idea why?

On 19/01/15 16:34, Jeff MAURY wrote:
You set plugin version to 1.07 and have a dependency on the same olugin excluding 1.0.1

Jeff

Le Mon Jan 19 2015 at 5:08:36 AM, Vadim Peretokin <Vadim.Peretokin@xxxxxxxxxxxx> a √©crit :
Hi,

I'm having difficulty with tycho-versions-plugin:0.21.0:set-version not updating a feature.xml file as it should be and I'm not certain what is causing the issue. I've got a multi-module project, cd'ing to the directory with the relevant pom and running mvn -Dtycho.mode=maven -Pnehta_mdht_ci org.eclipse.tycho:tycho-versions-plugin:set-version -DnewVersion=<new version> gives the following result:

[INFO] ------------------------------------------------------------------------
[INFO] Building NEHTA MDHT UI Plugins 1.0.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] --- tycho-versions-plugin:0.21.0:set-version (default-cli) @ au.gov.nehta.mdht.uml.cda.ui ---
[INFO] Making changes in /home/vadi/Desktop/bamboo/mdht/cda/plugins/au.gov.nehta.mdht.uml.cda.ui
[INFO]   pom.xml//project/version: 1.0.0-SNAPSHOT => 1.0.7
[INFO]   META-INF/MANIFEST.MF//Bundle-Version: 1.0.0.qualifier => 1.0.7
[INFO]   META-INF/MANIFEST.MF//Export-Package//version: 1.0.0.qualifier => 1.0.7
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------

The changes seem pretty localised, and they are, as a features.xml for au.gov.nehta.mdht.uml.cda.feature which has this listed is not being updated:

   <plugin
         id="au.gov.nehta.mdht.uml.cda.ui"
         download-size="0"
         install-size="0"
         version="1.0.0.qualifier"
         unpack="false"/>

Which of course leads to an issue during build:

16-Jan-2015 16:10:02    [ERROR] Cannot resolve project dependencies:
16-Jan-2015 16:10:02    [ERROR]   Software being installed: au.gov.nehta.mdht.updatesite raw:2.0.0.'SNAPSHOT'/format(n[.n=0;[.n=0;[-S]]]):2.0.0-SNAPSHOT
16-Jan-2015 16:10:02    [ERROR]   Missing requirement: au.gov.nehta.mdht.uml.cda.feature.feature.group 1.0.0.qualifier requires 'au.gov.nehta.mdht.uml.cda.ui [1.0.0,1.0.1)' but it could not be found
16-Jan-2015 16:10:02    [ERROR]   Cannot satisfy dependency: au.gov.nehta.mdht.updatesite raw:2.0.0.'SNAPSHOT'/format(n[.n=0;[.n=0;[-S]]]):2.0.0-SNAPSHOT depends on: au.gov.nehta.mdht.uml.cda.feature.feature.group [1.0.0,1.0.1)

What am I possibly doing wrong?

--

Vadim Peretokin
Clinical Information Modeller
nehta - National E-Health Transition Authority
Level 31, 400 George Street, QLD 4000, Australia
Phone: (0) 3023 8573
Email: vadim.peretokin@xxxxxxxxxxxx
Web: www.nehta.gov.au



The information contained in this e-mail message and any accompanying files is or may be privileged or confidential. If you are not the intended recipient, any use, dissemination, reliance, forwarding, printing or copying of this e-mail or any attached files is unauthorised. This e-mail and any attachments may be subject to copyright. Copyright material should not be reproduced, adapted or communicated without the written consent of the copyright owner. If you have received this e-mail in error please advise the sender immediately by return e-mail or telephone and delete all copies. NEHTA does not make any representations or give any guarantees in respect of the accuracy or completeness of any information contained in this e-mail or attached files. Internet communications are not secure, therefore NEHTA does not accept any liability for the contents of this message or attached files.
_______________________________________________
tycho-user mailing list
tycho-user@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/tycho-user



The information contained in this e-mail message and any accompanying files is or may be privileged or confidential. If you are not the intended recipient, any use, dissemination, reliance, forwarding, printing or copying of this e-mail or any attached files is unauthorised. This e-mail and any attachments may be subject to copyright. Copyright material should not be reproduced, adapted or communicated without the written consent of the copyright owner. If you have received this e-mail in error please advise the sender immediately by return e-mail or telephone and delete all copies. NEHTA does not make any representations or give any guarantees in respect of the accuracy or completeness of any information contained in this e-mail or attached files. Internet communications are not secure, therefore NEHTA does not accept any liability for the contents of this message or attached files.

Back to the top