[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[tycho-user] Fail to run generate-poms

I got cuple of artical like : http://zeroturnaround.com/labs/building-eclipse-plug-ins-with-maven-3-and-tycho/
 
the first step is create pom.xml by :
     
      mvn org.eclipse.tycho:tycho-pomgenerator-plugin:generate-poms -DgroupId=com.vogella.tycho.build
 
I never run it successly, i think there is something misunderstanding, i will write down my understanding, if i'm wrong, please correct me, thanks.
 
Before that, i need install mvn3 first and what i got is 3.0.4
 
And then open command-line, create a umpty folder, go into this new folder, run this:
 
      mvn org.eclipse.tycho:tycho-pomgenerator-plugin:generate-poms -DgroupId=com.vogella.tycho.build
 
And then i got this:
 
C:\Users\xx\Documents\peter\test4>mvn3 org.eclipse.tycho:tycho-pomgenerator-plugin:generate-poms -DgroupId=com.vogella.tycho.build
[INFO] Scanning for projects...
Downloading: http://repo.maven.apache.org/maven2/org/eclipse/tycho/tycho-pomgenerator-plugin/maven-metadata.xml
[WARNING] Could not transfer metadata org.eclipse.tycho:tycho-pomgenerator-plugin/maven-metadata.xml from/to central (http://repo.maven.apache.org/maven2): Connection to http://repo.maven.apache.org refused
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 23.839s
[INFO] Finished at: Tue Oct 09 14:33:00 BST 2012
[INFO] Final Memory: 2M/15M
[INFO] ------------------------------------------------------------------------
[ERROR] Error resolving version for plugin 'org.eclipse.tycho:tycho-pomgenerator-plugin' from the repositories [local (C:\Users\xx\.m3), central (http://repo.maven.apache.org/maven2)]: Plugin not found in any plugin repository -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginVersionResolutionException
 
 
And then i tried to specific the version number like this:
 
       mvn3 org.eclipse.tycho:tycho-pomgenerator-plugin:0.15.0:generate-poms -DgroupId=com.vogella.tycho.build
 
And it end up with:
 
C:\Users\xx\Documents\peter\test4>mvn3 org.eclipse.tycho:tycho-pomgenerator-plugin:0.15.0:generate-poms -DgroupId=com.vogella.tycho.build
[INFO] Scanning for projects...
Downloading: http://repo.maven.apache.org/maven2/org/eclipse/tycho/tycho-pomgenerator-plugin/0.15.0/tycho-pomgenerator-plugin-0.15.0.pom
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 21.545s
[INFO] Finished at: Tue Oct 09 14:36:25 BST 2012
[INFO] Final Memory: 2M/15M
[INFO] ------------------------------------------------------------------------
[ERROR] Plugin org.eclipse.tycho:tycho-pomgenerator-plugin:0.15.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.eclipse.tycho:tycho-pomgenerator-plugin:jar:0.15.0: Could not transfer artifact org.eclipse.tycho:tycho-pomgenerator-plugin:pom:0.15.0 from/to central (http://repo.maven.apache.org/maven2): Connection to http://repo.maven.apache.org refused: Connection timed out: connect -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
 
 
Any reply will be great help, thanks.