[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-user] broken Fedora builds

You don't need "a.jre 1.6". What you need is proper java profile
support, i.e. be able to compile projects against specific profile
configured in project <executionEnvironment> and fail the install of
your project if required profile is not provided by the runtime. We are
getting there, but there are still couple of outstanding issues in this
area in 0.16, afaict.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=385703
https://bugs.eclipse.org/bugs/show_bug.cgi?id=385930

--
Regards,
Igor

On 12-10-04 11:23 AM, Krzysztof Daniel wrote:
Tycho is heavily used in Fedora to build eclipse related stuff
(including Eclipse Platform).

We forced Tycho to use java 6 as the lowest possible requirement (a
small modification) to reduce the number of external dependencies and
use Fedora preinstalled JDK 7, but our recent builds started to fail
with:

org.apache.maven.InternalErrorException: Internal error:
java.lang.RuntimeException: "No solution found because the problem is
unsatisfiable.": ["Unable to satisfy dependency from config.a.jre 1.6.0
to a.jre 1.6.0.", "Unable to satisfy dependency from
org.apache.geronimo.specs.geronimo-annotation_1.1_spec 1.0.0 to package
javax.lang.model 0.0.0.", "Unable to satisfy dependency from
org.apache.geronimo.specs.geronimo-annotation_1.1_spec 1.0.0 to package
javax.lang.model.element 0.0.0.", "Unable to satisfy dependency from
org.apache.geronimo.specs.geronimo-annotation_1.1_spec 1.0.0 to package
javax.lang.model.util 0.0.0.", "Unable to satisfy dependency from
org.apache.geronimo.specs.geronimo-annotation_1.1_spec 1.0.0 to package
javax.tools 0.0.0.", "Unable to satisfy dependency from org.osgi.core
4.1.0 to package javax.security.auth.x500 0.0.0.", "Unable to satisfy
dependency from tycho-1349356468450 0.0.0.1349356468450 to a.jre
[1.6.0].", "No solution found because the problem is unsatisfiable."]

this looks like a direct result of
http://git.eclipse.org/c/tycho/org.eclipse.tycho.git/diff/tycho-bundles/org.eclipse.tycho.p2.resolver.impl/src/main/java/org/eclipse/tycho/p2/target/JREInstallableUnits.java?id=4952d643edc5458e7ae38fed2cabec7062a927c5 .
I must admit I don't fully understand the patch, but it looks like the
a.jre 1.6 is no longer present (the comment in the code says:
"We provide those IUs as empty shells").

My question is - how can I get the a.jre 1.6 back with all the packages
that are there without duplicating the existing vm installation?