[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[tycho-user] why can't update features of a built sdk/ide product?

Hi,

I have a p2 repository built by tycho with a set of features (containing eclipse plugins) that are being used properly. I can install and update them from the p2 server in any eclipse ide downloaded from eclipse.org.

I have created a product project that creates an eclipse ide/sdk where I'm including the features from my p2.

The sdk seem to be ok and is working properly. until when I needed to update those features.

Update manager don't detect the changes but I can select the new features in the Install.

And I'm getting some message errors:

Your original request has been modified.
"Lunifera Behavior Requirement Modeling Tools" is already installed, so an update will be performed instead.
"Lunifera Business Knowledge Modeling Tools" is already installed, so an update will be performed instead.
"Lunifera Component Modeling Tools" is already installed, so an update will be performed instead.
"Lunifera Eclipse UI Common Feature" is already installed, so an update will be performed instead.
"Lunifera Entities Modeling Tool" is already installed, so an update will be performed instead.
"Lunifera Organization Modeling Tool" is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: Lunifera Business Knowledge Modeling Tools 0.0.1.201209130007 (org.lunifera.feature.eclipse.modeling.business_knowledge.feature.group 0.0.1.201209130007)
Software currently installed: Lunifera IDE 0.0.1.201209122343 (LuniferaIDE 0.0.1.201209122343)
Only one of the following can be installed at once:
org.lunifera.metamodel.dsl.business.processes 0.0.1.201209130007 (org.lunifera.metamodel.dsl.business.processes 0.0.1.201209130007)
org.lunifera.metamodel.dsl.business.processes 0.0.1.201209122327 (org.lunifera.metamodel.dsl.business.processes 0.0.1.201209122327)
Cannot satisfy dependency:
From: Lunifera IDE 0.0.1.201209122343 (LuniferaIDE 0.0.1.201209122343)
To: org.lunifera.feature.eclipse.modeling.business_knowledge.feature.group [0.0.1.201209122327]
Cannot satisfy dependency:
From: Lunifera Business Knowledge Modeling Tools 0.0.1.201209122327 (org.lunifera.feature.eclipse.modeling.business_knowledge.feature.group 0.0.1.201209122327)
To: org.lunifera.metamodel.dsl.business.processes [0.0.1.201209122327]
Cannot satisfy dependency:
From: Lunifera Business Knowledge Modeling Tools 0.0.1.201209130007 (org.lunifera.feature.eclipse.modeling.business_knowledge.feature.group 0.0.1.201209130007)
To: org.lunifera.metamodel.dsl.business.processes [0.0.1.201209130007]


have someone experienced something like this? what am I missing?

thanks for any tip,

Cristiano