[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-user] Generated product contains unwanted optional dependencies

Indeed this never caught my eyes, an especially I was expecting the includeAllDependencies property to work for product too.
Now that I know what to search for, I can see it at  http://wiki.eclipse.org/Tycho/Target_Platform 

By the way is there a place where the tycho plugins documentation sites are published? I often find the "core" maven ones pretty useful.

Thank you
Vivien

On Tue, Sep 11, 2012 at 4:51 PM, Oberlies, Tobias <tobias.oberlies@xxxxxxx> wrote:

This is a frequently asked question, but apparently it seems to be hard to find the previous answers.

 

Therefore I have posted the question (and an answer) on stackoverflow.com: http://stackoverflow.com/questions/12372269/eclipse-rcp-built-by-tycho-includes-unwanted-optional-dependencies

 

If you are not doing it yet, I would also encourage you to ask questions on stackoverflow yourself. It’s a great system that makes it very likely you quickly get good answers. Also, others with the same problem can more easily benefit more from your learnings than if you ask on a mailing list.

 

Regards

Tobias

 

 

From: tycho-user-bounces@xxxxxxxxxxx [mailto:tycho-user-bounces@xxxxxxxxxxx] On Behalf Of vtintillier
Sent: Mittwoch, 5. September 2012 11:05
To: tycho-user@xxxxxxxxxxx
Subject: [tycho-user] Generated product contains unwanted optional dependencies

 

Hello,

 

I try to move a PDE build to Tycho. One of my issue is with the product generation.

- I use packaging type eclipse-repository.

- my product only contains my feature.

- my feature contains org.eclipse.core.runtime, which has an optional dependency on org.eclipse.core.runtime.compatibility.auth

- my feature does not contain org.eclipse.core.runtime.compatibility.auth

 

However in the resulting product, I get optional dependency org.eclipse.core.runtime.compatibility.auth included.

I created another project of type eclipse-repository, but which is based on a category.xml file. In the resulting zip, the optional dependency org.eclipse.core.runtime.compatibility.auth is NOT present, as expected.

 

For test prurpose, I added to the repository project the includeAllDependencies configuration of plugin tycho-p2-repository-plugin:

 

<build>

  <plugins>

      <plugin>

        <groupId>org.eclipse.tycho</groupId>

        <artifactId>tycho-p2-repository-plugin</artifactId>

        <version>0.15.0</version>

        <configuration>

          <includeAllDependencies>true</includeAllDependencies>

        </configuration>

      </plugin>

  </plugins>

</build>

 

In this case the optional dependencies are included in the p2 repository zip.

So I tried adding the opposite configuration to the product project:

 

<build>

  <plugins>

      <plugin>

        <groupId>org.eclipse.tycho</groupId>

        <artifactId>tycho-p2-repository-plugin</artifactId>

        <version>0.15.0</version>

        <configuration>

          <includeAllDependencies>false</includeAllDependencies>

        </configuration>

      </plugin>

  </plugins>

</build>

 

But still the optional dependencies are present.

 

Do you know how I can force product generation to not include optional dependencies?

 

Thank you

Vivien


_______________________________________________
tycho-user mailing list
tycho-user@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/tycho-user