[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-user] Tycho resolving always latest version for dependency

I recognize this question ;-)

 

There is an answer here: http://stackoverflow.com/questions/12349934/tycho-resolves-the-wrong-version-of-my-own-manifest-first-artifacts

 

Regards

Tobias

 

From: tycho-user-bounces@xxxxxxxxxxx [mailto:tycho-user-bounces@xxxxxxxxxxx] On Behalf Of Stefan Klaus
Sent: Montag, 10. September 2012 12:26
To: tycho-user@xxxxxxxxxxx
Subject: [tycho-user] Tycho resolving always latest version for dependency

 

Hi there!

Following scenario. My Application has some dependencies on my own pom-first Artifacts (build with pure maven) and some on my own manifest-first Artifacts (build with tycho). For the pom-first Artifacts tycho resolves exact the version i specified in the pom. For the manifest-first Artifacts tycho resolves the local built units (logging: [WARNING] The following locally built units...) which may have a higher version.

To be more precisly:
My dependency in pom.xml has version 1.2.0 but i receive with the above warning 1.3.0.2012xxx.

I have already found following bugs and discussions, but i dont understand why there is a difference in tycho resolving pom-first and manifest-first dependencies.

- https://bugs.eclipse.org/bugs/show_bug.cgi?id=355367
- http://dev.eclipse.org/mhonarc/lists/tycho-user/msg01673.html
- http://dev.eclipse.org/mhonarc/lists/tycho-user/msg01004.html

Thanks in advance
Stefan