[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-user] dependency to org.eclipse.objectteams.otdt.core.patch.feature.group from org.eclipse.jdt.core

It's basically an Eclipse bug. They ship JDT and JDT+patch, and if you depend on the JDT feature (which excludes the patch) you are OK: but if you depend on the package or it gets pulled in as a transitive dependency you're screwed. It's been that way for the last couple of releases. 

Unfortunately the only solution is to depend on the JDT feature, which brings in the UI as well. If this isn't desired you have to create your own feature. 

Alex

https://bugs.eclipse.org/bugs/show_bug.cgi?id=350133

Sent from my iPhone 4S

On 19 Aug 2012, at 19:57, Max Spring <m2spring@xxxxxxxxxxxxx> wrote:

> I'm working on the Activiti Designer trunk
> (http://svn.codehaus.org/activiti/projects/designer/trunk/)
> building with Tycho 0.15.0
> (http://svn.codehaus.org/activiti/projects/designer/trunk/org.activiti.designer.parent/pom.xml).
> 
> Last Thursday, all of a sudden the build fails with this:
> 
>   "No solution found because the problem is unsatisfiable.":
>   ["Unable to satisfy dependency from
>       org.activiti.designer.feature.feature.group 5.9.3 to
>       org.eclipse.graphiti.feature.feature.group [0.9.0,0.9.1).",
>    "Unable to satisfy dependency from
>       org.eclipse.jdt.core 3.7.0.v_OTDT_r200_201106070730 to
>       org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).",
>    "Unable to satisfy dependency from
>       org.eclipse.jdt.core 3.7.1.v_OTDT_r201_201109101025 to
>       org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).",
>    "Unable to satisfy dependency from
>       org.eclipse.jdt.core 3.7.3.v_OTDT_r202_201202051448 to
>       org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).",
>    "No solution found because the problem is unsatisfiable."
>   ]
> 
> It has been building fine for long time until just a few days before.
> 
> It appeared to me this might be similar to
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=350133
> 
> How can I further troubleshoot this problem?
> Is there a workaround?
> 
> I'm not really using objectteams.
> 
> Thanks!
> -Max
> _______________________________________________
> tycho-user mailing list
> tycho-user@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/tycho-user