[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-dev] Does tycho build with OpenJDK 9?

https://git.eclipse.org/r/#/c/123503/ 

ïOn 29.05.18, 08:09, "tycho-dev-bounces@xxxxxxxxxxx on behalf of Aleksandar Kurtakov" <tycho-dev-bounces@xxxxxxxxxxx on behalf of akurtako@xxxxxxxxxx> wrote:

    
    
    On Tue, May 29, 2018 at 8:13 AM, Sievers, Jan 
    <jan.sievers@xxxxxxx> wrote:
    
    this code is used to detect the compilation bootclasspath with useJDK=BREE
    it forks a small main program using the configured JDK
    
    
    AFAIK eclipse platform is still using very old JDKs (1.4) and the bytecode level of the compiled Main needs to be able to run on the oldest JDK used
    
    
    
    
    Eclipse platform requires 1.8  and equinox is still at 1.7. There are bundles at older but I don't see a reason for bundles there to stay at that level (http://download.eclipse.org/eclipse/downloads/drops4/I20180528-0800/buildlogs/reporeports/reports/breedata.txt
     for details). Overall bundles at ancient BREE are fading out so let's discuss the best for Tycho as a project here.
    
    
     
    
    
    
    Regards
    Jan
    
    
    On 28.05.18, 22:11, "tycho-dev-bounces@xxxxxxxxxxx on behalf of Aleksandar Kurtakov" <tycho-dev-bounces@xxxxxxxxxxx on behalf of
    akurtako@xxxxxxxxxx> wrote:
    
    
    
        On Mon, May 28, 2018 at 4:43 PM, Mickael Istria 
        <mistria@xxxxxxxxxx> wrote:
    
        Hi all,
    
    
        I cannot build locally today, I see 
    
        """
    
        [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.7.0:compile (default-compile) on project tycho-lib-detector: Compilation failure: Compilation failure:
    
        [ERROR] Source option 1.3 is no longer supported. Use 1.6 or later.
        [ERROR] Target option 1.1 is no longer supported. Use 1.6 or later.
        [ERROR] -> [Help 1]
    
    
    
    
    
        IMHO all these should be updated to 1.6+. Anything older than that should be out of question especially considering that Java 11 is supposed to drop even 1.6.  The fact that there is no OSS full featured pre 1.6 JVM makes it more than obvious for OSS projects
         to me.
    
        Jan, do you agree with bumping to Java 1.6+ so compiling with latest Java (10 at time of writing is working well) and working with latest LTS Java (8 at time of writing).
    
    
    
    
        """
    
    
    
        I'm using openjdk 9 here. 
    
        """
        mistria@mistria-rh:~/git/org.eclipse.tycho$ javac -version
        javac 9.0.4
        mistria@mistria-rh:~/git/org.eclipse.tycho$ java -version
        openjdk version "9.0.4"
        OpenJDK Runtime Environment (build 9.0.4+11)
        OpenJDK 64-Bit Server VM (build 9.0.4+11, mixed mode)
        """
    
    
        Are there some restriction about which JDK should be used in order to built Tycho? Or is there anything else I need to tweak?
    
    
        -- 
        Mickael Istria
    
        Eclipse IDE <https://www.eclipse.org/downloads/eclipse-packages/> developer, for
        Red Hat Developers <https://developers.redhat.com/>
        
    
    
    
    
    
    
    
        _______________________________________________
        tycho-dev mailing list
        tycho-dev@xxxxxxxxxxx
        To change your delivery options, retrieve your password, or unsubscribe from this list, visit
        
    https://dev.eclipse.org/mailman/listinfo/tycho-dev <https://dev.eclipse.org/mailman/listinfo/tycho-dev>
    
    
    
    
    
    
        -- 
        Alexander Kurtakov
    
        Red Hat Eclipse Team
    
    
    
    
    
    
    _______________________________________________
    tycho-dev mailing list
    tycho-dev@xxxxxxxxxxx
    To change your delivery options, retrieve your password, or unsubscribe from this list, visit
    https://dev.eclipse.org/mailman/listinfo/tycho-dev
    
    
    
    
    
    
    
    -- 
    Alexander Kurtakov
    
    Red Hat Eclipse Team