[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-dev] CQ for snappy java

if we need plexus-archiver and plexus-archiver now transitively requires snappy-java (which contains GPL code) then that's a no-go from an IP point of view.
One thing you could try as last resort is exclude [1] snappy-java to see if we actually need it or not (this is highly error prone though).

Failing that we need to step back and think about alternative solutions to the original problem.

Regards
Jan

[1] https://maven.apache.org/guides/introduction/introduction-to-optional-and-excludes-dependencies.html 


From: tycho-dev-bounces@xxxxxxxxxxx [mailto:tycho-dev-bounces@xxxxxxxxxxx] On Behalf Of SCHREIBER.Martin
Sent: Mittwoch, 20. Mai 2015 07:59
To: Tycho developers list
Subject: [tycho-dev] CQ for snappy java

Hi,

for resolving the bug regarding invalid zip files for very large repositories [1], I created different CQs for updating the plexus-archiver and all it's depenencies.
One of the dependencies is snappy-java. 
The new version of snappy-java seems to contain stuff that is not compatible with the EPL (see CQ [2]). It might not be an issue since we do not ship snappy-java in any artifacts but I am not sure what the next steps regarding the CQs should be. So can someone help me out there please.

Thanks
Martin

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=461974c
[2] https://dev.eclipse.org/ipzilla/show_bug.cgi?id=9404

p.s. the other CQs needed for the bugfix are approved