So you specify Require-Bundle: abc;version="1.0.400.201206110847”?
If yes, it is totally valid to resolve this to 1.0.400.vXXX because
· the version attribute actually means version range, so you specified “1.0.400.201206110847 or larger”
· 1.0.400.vXXX is larger than 1.0.400.201206110847
From: tycho-dev-bounces@xxxxxxxxxxx [mailto:tycho-dev-bounces@xxxxxxxxxxx] On Behalf Of Mickael Istria
Sent: Dienstag, 12. Juni 2012 16:08
Subject: Re: [tycho-dev] Override Equinox implementation?
On 06/12/2012 03:39 PM, Igor Fedorenko wrote:
But p2 is already locked to a specific fully qualified version by
org.eclipse.sdk.ide, no? Trying to specify another version of p2 will
result in resolution failures, unless I am missing something.
Actually I tried that, and it results in build using 1.0.400.vXXX (remote) dependency even when I set version to 1.0.400.201206110847 (local one). The almost looks like a bug. I also tried with a <repository> instead of a target-platform-configuration, and got the same resolution from 1.0.400.201206110847 to 1.0.400.vXXX ! Looks like resolution ignores qualifier.
With 1.0.500, it is working better: when setting dep to 1.0.500 then resolution goes to my local bundle. But it is annoying since it forces me to make modification in p2 poms and MANIFEST.
So I'm no more blocked anymore, but I think there is a place for improvement here.