|[tracecompass-dev] Help naming a plugin|
The title says it all, I need help naming a new plugin! Because renaming them later is such a pain.
I discussed with some of you about a new plugin that will store information about a system/host/machine, eventually farm/virtual environment, etc.
What's the goal of this plugin? It will provide various information about a system, if it is available, to analyses and views, transparently from the analysis that extracted it and without having to create dependencies with the package that contains the analysis that provides the information.
For example, I have a trace that provides a callstack, where the events have a tid. That trace can be a JUL log file. More than just the duration of the callstack events, I want to know the time of CPU. I happen to have a kernel trace somewhere that can provide this information. Right now, it would have to depend on o.e.t.analysis.os.core to get the only analysis that I know provides this information. Instead, it would depend on this new plugin that will "magically" know that there is an analysis for this host that provides the required data.
In the short term, the "model" provided by the new plugin will just use the current analyses (without dependencies to the plugins that contain them) to provide information.
In the long term, the plan is that analyses, instead of populating each their own little state system, will populate this model directly (and the model will decide how/if state system(s) will be populated) so that analyses for different traces for a same machine can populate the same model. Typical use case of this would be for example multiple threads named 'java' in a control flow view populated by a kernel trace. A JUL trace of that same execution will know that thread 543 is called "Event request" between time x and y, so it will add this information to the model and it will show in the control flow view.
The initial name I had for this plugin is o.e.t.analysis.os.core, but the 'os' part is wrong, it's more than that. Patrick suggested offline simply o.e.t.analysis.core. Sounds about right but it removes one level in the name. Any objection to that? Any better suggestion?
For the curious, see  for the patch implementing this new plugin
Back to the top