[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [stp-dev] takin' a look at the core model code

Hi guys,

        The Eclipse standard naming conventions  ([1])  are as follows :


So for the code in the Code project, we have:

org.eclipse.stp.core.<pkg> : API package (all API currently experimental)
org.eclipse.stp.core.internal.<pkg> : Internal package.  Note that this is different than what you have below.

The test plugins are named:

org.eclipse.stp.core.tests.<subclassifier>. There is one test plugin for the core plugin, and another test plugin for the infrastructure code (org.eclipse.stp.core.tests.infrastructure.

In other subprojects, like SOAS, you'll want something like:

org.eclipse.stp.<subproject>.<pkg>: API
org.eclipse.stp.<subproject>.internal.<pkg> : Internal
org.eclipse.stp.<subproject>.tests.<pkg> : Tests

Where <subproject> is something like "soas" or "assembly" or whatever you come up with. Using "System" could be confusing for newcomers (especially since SCA doesn't have a System model object, but does go to Subsystem). What about "deployment" ("org.eclipse.stp.deployment") since (from my understanding) the purpose of the SOAS subproject is to prepare the SCA deployables?

[1] http://dev.eclipse.org/naming.html
Kind Regards,

Michael D. Elder
Rational Studio / Services Tools Development    
Ext: (919) 543-8356
T/L:  441-8356

Naci Dai <naci.dai@xxxxxxxxxxxxx>
Sent by: stp-dev-bounces@xxxxxxxxxxx

04/05/2006 12:40 AM

Please respond to
STP Dev list <stp-dev@xxxxxxxxxxx>

STP Dev list <stp-dev@xxxxxxxxxxx>
Re: [stp-dev] takin' a look at the core model code

Hi Oisin,

sdk stands for software development kit.  This is a packaging feature
which includes the sources. SDK are useful for adopters and developers
so that they have the sources readily available.  So we will have a
runtime zip (all binaries) and an sdk zip (runtime+sources).

I will also suggest that we drop  "assembly" in the feature chain as the
top level features of each project is already doing that.

tests and internal are fine.

- Builds are ready and tested we are waiting for the current code to be
renamed and promoted to CVS to start builds.

>> -Have you decided about the name conversion for the contibuted
>> plugins? i.e (org.eclipse.stp.sca.**??)
> Suggest org.eclipse.stp.core as a base, then subpackage from there
> to
> com.ibm.ccl.soa.core -->  org.eclipse.stp.core.assembly
> com.ibm.ccl.soa.core.sca -->   org.eclipse.stp.core.assembly.model
> com.ibm.ccl.soa.internal.core --> org.eclipse.stp.core.assembly.internal
> com.ibm.ccl.soa.internal.core.sca -->
> org.eclipse.stp.core.assembly.internal.model
> Is the 'internal' in the right place here?  Put '.tests' on the end
> for the tests of course.
> com.ibm.ccl.soa.infrastructure -->
> org.eclipse.stp.core.assembly.infrastructure
>> -We also added two top level assembly projects to drive the builds
>> and represent the subproject (we called it org.eclipse.stp.sca and
>> org.eclipse.stp.sca.sdk for lack of anything else).  Any ideas?
> Perhaps:
> org.eclipse.stp.core.assembly
> org.eclipse.stp.core.assembly.sdk
> what's the sdk indicate here Naci?
>> - Finally test plugin IDs  and project names do not match.  Minor
>> point but worth fixing during the conversion.
> Yup I think so.
>  --oh
> _______________________________________________
> stp-dev mailing list
> stp-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/stp-dev

stp-dev mailing list