[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[platform-ui-dev] Fwd: New year brings new ICU version, 4.2.x

Just a reminder that the platform will be introducing a new version
ICU4J, bundle com.ibm.icu.

Eclipse 3.6 will ship with version 4.2.2 in July, and we should be
upgrading the version in the platform for Helios M5 (to 4.2.1)

What do consuming projects have to do?  Make sure your ICU
Import-Package statements don't have an upper bound, especially an
exclusionary bound "..., 4.2.0)".

PW

---------- Forwarded message ----------
From: Paul Webster <pwebster@xxxxxxxxxxxxxxxxxxx>
Date: Tue, Dec 8, 2009 at 11:38 AM
Subject: New year brings new ICU version, 4.2.x
To: "General development mailing list of the Eclipse project."
<eclipse-dev@xxxxxxxxxxx>, "Eclipse Platform UI component developers
list." <platform-ui-dev@xxxxxxxxxxx>


This has also been brought up on the Cross Projects Mailing List

In the new year, (i.e. hopefully by Helios M5) the platform will be
including [1] the new(er) version of ICU4J [2], ICU 4.2.x (4.2.1
followed by 4.2.2 before Helios ships).

There are no major API changes (just a reminder that ICU is an
external project, and so does not follow our API version conventions
[3] )

What do consuming projects have to do? ÂMake sure your ICU
Import-Package statements don't have an upper bound, especially an
exclusionary bound "..., 4.2.0)".

Also of interest: ÂThe ICU project will be releasing 4.4 in March
2010, and the API will include 1.5 features (Generics, Enums, etc).
But the Eclipse Platform has no plans to adopt 4.4 at this time.


[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=297077
[2] http://site.icu-project.org/
[3] http://wiki.eclipse.org/Version_Numbering

--
Paul Webster
Hi floor. ÂMake me a sammich! - GIR



-- 
Paul Webster
Hi floor.  Make me a sammich! - GIR