Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [platform-ui-dev] Component framework proposal version 1.0.4 available


I'm good with renaming the class attribute to implementation and the interface attribute to parameter if everyone else is.

There is no plan to support setter injection. Supporting two ways of doing the same thing will make downstream code inconsistent. The only reason I mention the "optional parameters" pattern in the specification is to ensure consistency. If this wasn't part of the framework, then 100s of downstream plugins would end up registering their own IOptionalParameters interface.

  - Stefan



"Ed Burnette" <Ed.Burnette@xxxxxxx>
Sent by: platform-ui-dev-admin@xxxxxxxxxxx

11/09/2004 10:43 PM

Please respond to
platform-ui-dev

To
<platform-ui-dev@xxxxxxxxxxx>
cc
Subject
RE: [platform-ui-dev] Component framework proposal version 1.0.4 available





>                 For more on constructor injection, see www.picocontainer.org.

Ok, after reading picocontainer.org and the references there it makes more sense. You should definitely include that in the doc.

>                 I suspect you're commenting on the heavy usage of the word "interface". Would
> "specification" be better?

No, that would be worse. Maybe you should use the PicoContainer terminology such as parameters and implementations.

The Fowler paper at http://www.martinfowler.com/articles/injection.html recommends that frameworks implement both Constructor and Setter injection. Also it doesn't have anything about your optional parameters (section 2.8). Since you're discouraging optional parameters yourself, if you had Setter injection maybe optional parameters wouldn't be needed at all.
_______________________________________________
platform-ui-dev mailing list
platform-ui-dev@xxxxxxxxxxx
http://dev.eclipse.org/mailman/listinfo/platform-ui-dev


Back to the top