Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[platform-ui-dev] Changes to the activities API for M9

We've released a change to the activities API into M9.  We feel this change is necessary for the sake of clarity and is low risk.  The definition for an activityActivityBinding was confusing and even misleading.  The name was cumbersome and the manner in which you described the requirement relationship didn't lend well to the child/parent naming scheme.  The schema and Java API definitions for activityActivityBinding have been renamed to activityRequirementBinding.  Additionally, the parameters childActivityId and parentActivityId have been renamed to requiredActivityId and activityId respectively.   The behavior of these bindings has not changed in any way.  Please see for further details.  

Sorry for any inconvenience this may cause.

Back to the top