Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [platform-ui-dev] Proposal to rename Project menu to Workbench

I disagree (what a surpise eh!)

It is a well know usuability issue to use different names for the same
action. So we should make sure we use "Build" and "Rebuild All" everywhere.
The menu that contains it will define the scope of the action (i.e. in the
Workbench menu it applies to every resources, in the Project context menu,
it applies to the project's resources).

As for these actions showing up on elements under the project, we should be
looking at the original problem that caused these actions to show up on
these elements as a workaround solution. Let's assume after looking at the
problem we need to keep these actions on these elements under the project.
I still say we need to keep the labels "Build" &"Rebuild All" and not
"Build" & "Rebuild". Then we can prefix with Project just to clarify the
scope on these elements (in my opinion, it be better if the actions where
not on these elements)

Ok, I'm going to be quiet now... ;-)

Simon :-)

                    Sent by:                       To:     platform-ui-dev@xxxxxxxxxxx                      
                    platform-ui-dev-admin@e        cc:                                                      
                               Subject:     Re: [platform-ui-dev] Proposal to rename    
                                                   Project menu to Workbench                                
                    12/07/2001 10:03 AM                                                                     
                    Please respond to                                                                       

The Navigator and Packages views use "Build Project" and "Rebuild Project"
to make it clear that it is just the single project being built, not the
whole workspace.
Since some of the actions in the context menu apply to the selection and
some are global, I believe it helps to make this distinction so that
people don't think they're just shortcuts for the global build actions.
Also, in the Packages view, these items also appear when an element under
the project is selected.
It would be surprising if they changed names when the project was selected
vs. an element under it.
I recommend we leave them as is.

We should also have the Navigator present them when a non-project resource
is selected, for consistency with the packages view.


Sent by: platform-ui-dev-admin@xxxxxxxxxxx
12/07/01 09:04 AM
Please respond to platform-ui-dev

        To:     platform-ui-dev@xxxxxxxxxxx
        Subject:        Re: [platform-ui-dev] Proposal to rename Project
menu to Workbench


2) Some context menus started using their own variation of "Build" and
"Rebuild All". For example, there is a "Build Project" and "Rebuild
Project". Now people familiar with the other terms are confused. They look
kinda the same but do they do the same? I recommended that on the Project
context menu, we show "Build" and "Rebuild All". It is obvious to the user
the scope is the Project. On other resources, we can show "Project Build"
and "Project Rebuild All" (I'm not going to describe the reasons why this
was needed or if the problem could be solved in other ways - that may come
out in another proposal)

Simon :-)

platform-ui-dev mailing list

Back to the top