[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [pdt-dev] Odp.: Build path/ Include path
- From: Gadi Goldbarg <gadi@xxxxxxxx>
- Date: Mon, 25 Apr 2016 08:42:00 +0000
- Accept-language: en-US
- Delivered-to: email@example.com
- Thread-index: AQHRnsxHE94gPygy/EC2A+y99q/DN5+aXgxw
- Thread-topic: [pdt-dev] Odp.: Build path/ Include path
I have to say that it is very confusing to use Java names as in PHP there is no such thing as build path.
A PHP developer just needs to be able to specify which are his files for Include path ( e.g. his used code ). He doesn't really know what build path is !
( Build path is kind of internal for the IDE )
- Although Composer takes care of you most of the time not everyone is using it so we probably still need this way.
My 2 cents , so if you guys want to simplify just leave include path :)
From: pdt-dev-bounces@xxxxxxxxxxx [mailto:pdt-dev-bounces@xxxxxxxxxxx] On Behalf Of Thomas Gossmann
Sent: Monday, April 25, 2016 11:27 AM
To: PDT Developers <pdt-dev@xxxxxxxxxxx>
Subject: Re: [pdt-dev] Odp.: Build path/ Include path
my knowledge on include path (and also libraries) is very limited, I think it just got copied in, when DLTK provided such functionality.
Reducing it to just build path is what would help PDT a lot. Then build path would take 3 different types of entries:
- library folder
- project (see also )
 - https://bugs.eclipse.org/bugs/show_bug.cgi?id=492187
Am 24.04.16 um 20:56 schrieb Michal Niewrzal:
> My knowledge about include path management is very limited but +1 for
> every simplification around include path/build path 😊
> *Od:* pdt-dev-bounces@xxxxxxxxxxx <pdt-dev-bounces@xxxxxxxxxxx> w
> imieniu uÅytkownika Dawid PakuÅa <zulus@xxxxxxxxx>
> *WysÅane:* 24 kwietnia 2016 18:31
> *Do:* PDT Developers
> *Temat:* [pdt-dev] Build path/ Include path Hi,
> Iâm playing with bug 444226  and have two concerns.
> 1. Do we really need include path management in composer age, when
> PEAR is mostly dead? If yes can we just throw it away project
> provisional (see point 2) and keep it simple with âsync with build pathâ button/switch?
> 2. Rather than creating completly new widget (with ton of code to
> maintenance), maybe we could âjustâ migrate to standard DLTK
> BuildPathPropertyPage? + rename it to validation/index path. After
> that bug 472758 will be much simpler to resolve.
>  - https://bugs.eclipse.org/bugs/show_bug.cgi?id=444226
>  - https://bugs.eclipse.org/bugs/show_bug.cgi?id=472758
> Dawid PakuÅa
> pdt-dev mailing list
> To change your delivery options, retrieve your password, or
> unsubscribe from this list, visit
pdt-dev mailing list
To change your delivery options, retrieve your password, or unsubscribe from this list, visit https://dev.eclipse.org/mailman/listinfo/pdt-dev