[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [pdt-dev] rhino/nashorn js-scripts - jdk8

Hi,

Thank you for that! 

As I see in bug, make it compatible with JDK8 should be simple. Itâs time to install JDK 8 on my test machine ;)

--
Dawid PakuÅa 
+48 795 996 064

On 19 Jan 2015 at 14:16:09, Patrik Plihal (patrik.plihal@xxxxxxxxx) wrote:

Hello,

just wanted to point out that while pdt compiled fine with jdk8 (and
afaik should still) - a recent addition (compile.js somwhere in the help
package under /docs/build ) requires jdk < 8 since it uses the
'importPackage' statement, which in JDK8 does not exists anymore.

see
https://stackoverflow.com/questions/22531159/ant-script-importpackage-does-not-work-after-upgrading-to-ant-1-9-2

and
https://bugs.openjdk.java.net/browse/JDK-8025132


Regards Patrik



_______________________________________________
pdt-dev mailing list
pdt-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/pdt-dev