[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [pdt-dev] Question about Xdebug

> I guess I'll double post here, but I think found the culprit. For the NTS
> version you should use 'zend_extension' instead of 'zend_extension_ts' in
> your php.ini.

On PHP 5.3.x builds both NTS and TS builds should use 'zend_extension'.
It is only on builds before this that you specify '_ts' for the thread-safe builds.

> 2010/3/27 ????? ???????? <stoyanster@xxxxxxxxx>
> 
> > Hi there,
> >
> > version vc9 of the PHP is for using with IIS. I don't know if this is the
> > server of your choice. If you're using Apache's httpd use the VC6 version of
> > both the PHP and xdebug.
> >
> > On Sat, Mar 27, 2010 at 7:36 AM, ??? <zhaozhongwei@xxxxxxxxxxxxxxxx>wrote:
> >
> >> Hello everyone.
> >>
> >> I try to install xdebug on XP ,but i failed.
> >>
> >> PHP
> >> version:php-5.3.0-nts-Win32-VC9-x86,php-5.3.0-Win32-VC9-x86,php-5.3.2-nts-Win32-VC9-x86,php-5.3.2-Win32-VC9-x86.
> >> all of the above are zip version.
> >>
> >> php.ini:
> >>
> >> zend_extension_ts="F:\php\execute\php-5.3.0-Win32-VC9-x86\ext\php_xdebug-2.1.0beta3-5.3-vc9-nts.dll"
> >> for nts version
> >> zend_extension_ts="F:\php\execute\php-5.3.2-Win32-VC9-x86\ext\php_xdebug-2.0.5-5.3-vc9.dll"
> >> for ts version
> >>
> >> xdebug
> >> version:php_xdebug-2.0.5-5.3-vc9.dll,php_xdebug-2.1.0beta3-5.3-vc9.dll,php_xdebug-2.1.0beta3-5.3-vc9-nts.dll
> >>
> >> I run php -m command in relative directory,but i saw there is no xdebug
> >> installed,and i try to debug php script ,and it did not stop at the
> >> breakpoints.
> >>
> >>
> >> So where am i wrong?
> >>
> >> Thanks!
> >> --
> >>
> >> Thanks!
> >>
> >> Best Regards!
> >>
> >> Zhao
> >>
--
Niel Archer
niel.archer (at) blueyonder.co.uk