[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[pdt-dev] Re: [Dltk-dev] PDT Crashes

Hi all,

CC: to pdt-dev, since the subject is mostly related to PDT.

I think I have restored compatibility of VariableKind class, since it was a recent change and is mentioned in the links below.
Do you know if there are other incompatible API changes?

Do you wish to check it PDT 2.0 compiles/works with DLTK-HEAD?
Do you want to detect the latest DLTK version working with PDT 2.0?

Thank you,
Alex

----- Original Message -----
From: "Renato Silva" <br.renatosilva@xxxxxxxxx>
To: "DLTK Developer Discussions" <dltk-dev@xxxxxxxxxxx>
Sent: Friday, June 19, 2009 12:06:37 PM GMT +06:00 Almaty, Novosibirsk
Subject: [Dltk-dev] PDT Crashes

People are reporting the same problem out there:

http://www.eclipse.org/newsportal/article.php?id=3757&group=eclipse.tools.pdt#3757

https://bugs.eclipse.org/bugs/show_bug.cgi?id=280652


Alex, you told me we can use 1.0M4 which would work with PDT 2.0: http://dev.eclipse.org/mhonarc/lists/dltk-dev/msg01681.html

However, as PDT 2.0 + DLTK integration builds were working nicely a few weeks ago, it seems to me that even tough the code has changed a lot from M4, only recent changes made DLTK imcompatible with PDT. Unfortunately, it seems that PDT 2.1 which would be comaptible with latest DLTK builds, on the other hand are incompatibe with Ganymede.

My suggestion is to detect what is the latest DLTK version working with PDT 2.0, from the last few weeks, and then create another similar update site, something like http://download.eclipse.org/technology/dltk/updates-dev/ganymede, and a branch in CVS repo, for maintenance.

I think that many people are still using Ganymede + PDT, and I think it would be nice to give them some support for a while.

_______________________________________________ dltk-dev mailing list dltk-dev@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/dltk-dev