[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [pdt-dev] How to make PDT-Eclipse use Sun-JDK instead of GCJ

Thanks Wayne...Following steps did the trick:

sudo update-alternatives --config java
sudo update-alternatives --config javac
sudo update-alternatives --config jar


Now while starting Eclipse, it didn't say that it is using GCJ.

You can configure Eclipse to use a specific JRE when it runs (independent of what's installed/configured on Ubuntu)

I believe now I am using Sun-Java. Do I still need to configure Eclipse to use specific JRE. If yes then please do tell me.

I apologise if my questions are too childish. I have never used eclipse and never worked on Java. I am more of 'vim' editor lover.

Cheers,
Parag,
Software Engineer, PERSISTENT Systems LTD,
http://www.persistentsys.com/



Will Rogers Â- "I don't make jokes. I just watch the government and report the facts."

On Mon, Apr 27, 2009 at 12:55 AM, Wayne Beaton <wayne@xxxxxxxxxxx> wrote:
Don't do this. This step is for configuring the Eclipse environment to *build* Java applications. You need to configure the version of Java used to run Eclipse itself. This is an Ubuntu thing, not an Eclipse thing.

A little further down in the thread, the following steps are more useful:

another way to do this instead of making a link is

sudo update-alternatives --config java
sudo update-alternatives --config javac
sudo update-alternatives --config jar

this will give you a list of installed java
Choose sun java...
You can configure Eclipse to use a specific JRE when it runs (independent of what's installed/configured on Ubuntu); let us know if you want to try that.

Wayne


Parag Kalra wrote:
As I have downloaded PDT-Eclipse it is not having the JAVA section under:

Windows > Preferences > Java > Installed JRE

Could someone share the URL which I can use under 'HELP' -> 'Software
updates' -> 'Available software' -> 'Add site' and installed the JAVA IDE
feature into PDT-Eclipse.

Thanks in advance.

Cheers,
Parag,



On Sun, Apr 26, 2009 at 11:23 PM, Michael Spector <spektom@xxxxxxxxx> wrote:

Â
Hi,

Please read here: http://ubuntuforums.org/archive/index.php/t-64203.html

Thanks,

On Sun, Apr 26, 2009 at 8:51 PM, Parag Kalra <paragkalra@xxxxxxxxx> wrote:
 Â
Hello All,

When I am starting the PDT - Eclipse, I am getting a dialog box
  Â
displaying
 Â
following message:

  Â
GCJ has been detected as the current Java virtual machine. ÂUse of GCJ
   Â
is
 Â
untested and unsupported. ÂPlease consult the documentation for more
information.
   Â
However even by using GCJ, PDT-Eclipse is working as expected but still I
want o use Sun-JDK instead of GCJ.

Also Sun-JDK is installed on my Ubuntu 8.10. I just want to know the way
  Â
by
 Â
which I can switch between the two.

I guess un-installing GCJ is one of the option but I don't want to do
  Â
that.
 Â
Any other option?

Cheers,
Parag


Steven Wright Â- "A lot of people are afraid of heights. Not me, I'm
  Â
afraid
 Â
of widths."
_______________________________________________
pdt-dev mailing list
pdt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/pdt-dev


  Â

--
Best regards,
Michael
_______________________________________________
pdt-dev mailing list
pdt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/pdt-dev

 Â

Â------------------------------------------------------------------------


_______________________________________________
pdt-dev mailing list
pdt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/pdt-dev
Â
_______________________________________________
pdt-dev mailing list
pdt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/pdt-dev