[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [pdt-dev] Trouble running PDT - HelloWorld program

Hello Roy et All,

I guess I have already downloaded all-in-one PDT version of Eclipse. I am using the following version:

http://www.eclipse.org/downloads/download.php?file=/tools/pdt/downloads/drops/2.0.0/R200812290607/pdt-all-in-one-linux-gtk-2.0.0GA.tar.gz

I believe the version you want me to download is same as above. If thats the case then I believe I should have ZEND debuger present.

In that case could someone help me debug the issue and configure the ZEND debugger.

Cheers,
Parag,


On Sun, Apr 26, 2009 at 2:14 PM, Roy Ganor <roy@xxxxxxxx> wrote:

Hi,

As mentioned in the PDT downloads page:

Â

In order to be able to perform debugging using PDT, you should download one of the following extra packages:

ÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂ Zend PDT Community SiteÂPDT and Zend Debugger

ÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂ Xdebug SiteÂPDT and XDebug


Note: Due to Eclipse licensing requirements, PDT with debugger packages are distributed from external locations.Â

Â

If you are a newbie to PHP and PDT, I would recommend downloading the all in one with the php binaries and debuggers from http://zend.com/pdt

Â

Happy phping!

- Roy


From: pdt-dev-bounces@xxxxxxxxxxx [mailto:pdt-dev-bounces@xxxxxxxxxxx] On Behalf Of Parag Kalra
Sent: Sunday, April 26, 2009 11:13 AM
To: PDT Developers
Subject: Re: [pdt-dev] Trouble running PDT - HelloWorld program

Â

I am completely newbie in the world of PHP and Eclipse. Sorry to say but I even don't know what is a ZEND debugger.Â

Could someone please share some online documentation explaining how to configure Eclipse for PHP like installing and configuring ZEND debugger, making changes in 'php.ini' etc.

Cheers,
Parag

On Sun, Apr 26, 2009 at 1:21 PM, Michael Spector <spektom@xxxxxxxxx> wrote:

Hi,

Do you have Zend Debugger installed in /etc/php5/cli/php.ini ?

Thanks,


On Sun, Apr 26, 2009 at 10:09 AM, Parag Kalra <paragkalra@xxxxxxxxx> wrote:
> Hello All,
>
> I am a really new to this eclipse world and finding it difficult to handle.
>
> I have created a dummy project HelloWorld. Then added a simple PHP file to
> it - HelloWorld.php.
>
> # cat HelloWorld.php
>
> <?php
> echo "Hello World \n";
> ?>
>
> Under Project Properties -> Executable, I have set following settings:
>
> Executable name - php5
> Execuatable path - /usr/bin/php5
> PHP ini path - /etc/php5/cli/php.ini
> Debuger - Zend
>
> On running the file I am getting an error. PFA for the screenshot. However
> same file is running on the terminal.
>
> I think php.ini needs to be configured.
>
> Please suggest.
>
> Cheers,
> Parag,
>
> H. L. Mencken Â- "It is even harder for the average ape to believe that he
> has descended from man."

> _______________________________________________
> pdt-dev mailing list
> pdt-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/pdt-dev
>
>



--
Best regards,
Michael
_______________________________________________
pdt-dev mailing list
pdt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/pdt-dev

Â


_______________________________________________
pdt-dev mailing list
pdt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/pdt-dev


GIF image

GIF image