[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[mdt-papyrus.dev] EPL v2 for SysML 1.4 ?

Hi,

 

Eclipse public license v1.0 is now deprecated (see [1]), and it’s recommended to move to EPL v2.

In my understanding when simply moving from EPLv1 to EPLv2 there is no legal complexity

and headers and other files should be updated accordingly (See [2]).

 

Following Photon train release, I will publish a SysML 1.4 version compatible with Papyrus 4.0.0 (Photon)

This version will be number 1.3.0 and I want to take this opportunity  to update the license.

 

I created a dedicated bug [3] and also a patch [4]

 

Any comments ? It would be nice if someone can check the patch.

 

Related points:

-          I discovered the shared license concept in feature. (It would be nice to use it in Papyrus core)

-          Can we agree to change the name of Bundle-Vendor from Eclipse Modeling Project to (one of them)

o   Eclipse Papyrus Project

o   Papyrus Project

o   Eclipse.org Papyrus

o   (this are patterns used by other projects but I’m open to anything containing “Papyrus”)

o   => The main reason is to remove Papyrus prefix from the name of the plugins (should improve the clarity)

 

Regards,

Benoit

 

1 : https://www.eclipse.org/legal/epl-2.0/faq.php#h.60mjudroo8e5

2 : https://www.eclipse.org/legal/epl-2.0/faq.php#h.tci84nlsqpgw

3 :https://bugs.eclipse.org/bugs/show_bug.cgi?id=536295

4 :https://git.eclipse.org/r/#/c/125024/