Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [] Java Versions

What's EMF doing? We depend on its latest version.

-- Axel

On 3/23/2011 4:18 AM, Adolfo Sánchez-Barbudo Herrera wrote:
Ed, Axel, Laurent

Maybe I'm exposing stupid questions but I want to be sure we are all
speaking the same idiom, and please make any correction if necessary...

- What is "Develope with Java6" ? I guess you mean you using a JRE 1.6
to run our Eclipse IDE ?. In this case, I'm also using Java 1.6 and I
agree with axel the JVM 1.6 should increase our IDE performance. No
other side effects from the development point of view (Well, perhaps "a
side effect" is that you won't be able to create Java 1.6 code unless
you install other JREs: Window -> Prferences -> Java -> Installed JREs)

- What is "with Java 5 compatibility" ? I guess you mean configuring the
IDE (specifically, JDT) so that we can work with Java 1.5 code which:
1. can be compiled by a Java 1.5 compiler
2. the compiled byte code maybe executed by a JRE 1.5.
3. JDT helps us to deal with such a Java 1.5 code: Proper
warnings/errors in the editors, quick fixes suitable for the java 1.5
compiler, etc

This configuration is made doing the following : Window -> Preferences
-> Java -> Compiler -> Compiler compliance level: 1.5

- Which compiler should we use, to build our code ?
1. Using a Java 1.5 compiler, will produce bytecode executable by both
JRE 1.5 and JRE 1.6.
2. Using a Java 1.6 compiler, will produce bytecode executable only by
JRE 1.6 (Sometimes, I've found problems (bad class version execeptions)
around Eclipse due to this situation).

So, taking into account that we set the J2SE-1.5 as the required
execution environment we must probably compile our code with a Java 1.5
compiler, otherwise we are not complying with our own specifications.

On the other hand, David commented that Indigo installation will now
require a JRE1.6 which may invite us to change our minimun execution
environment requirement. However, Laurent has exposed a different use
case which having such a Java 1.5 compatibily could be useful (BTW
Laurent, have you tested an Indigo Acceleo + OCL in a Eclipse Ganymede
?¿? I'm very sceptical about this ;P ) ...

Furthermore, unless we need any specific need/advantage from Java 1.6,
I'm also inclined to keep the Java 1.5 compatibility.

Best Regards,

El 23/03/2011 9:17, Laurent Goubet escribió:

I may be a little late to react to this, and I'll react more as a
commiter on M2T/Acceleo than as a commiter on MDT/OCL... But I'll vote
for OCL to "develop in Java 6 with Java 5 compatibility". Acceleo is
widely used by clients that are still on Java 5, using Eclipses that
go sometimes all the way back to 3.4. OCL switching to use Java 6 only
features would force us (and other users of OCL-dependent tools) to
drop all compatibility options and switch to the latest Eclipse,
latest Java versions in order to use the latest Acceleo (and that's
something we've strived to avoid up till now).


On 17/03/2011 20:14, Axel Uhl wrote:
I'm running my Eclipse on 6 since a long time and only have a 5
installed for my OCL work as a target environment. The one thing that
finally would become possible with 6 is @Override for interface
methods (remember the initial hick-ups with my code cause by me being
on 6?). Other than that, performance for 6 is much better, but we
benefit from that also by just *executing* on 6; I don't expect major
improvements just from *compiling* with 6 instead of 5.

Anyway, I'm all for 6/6 after Indigo.

-- Axel

On 3/17/2011 5:50 PM, Ed Willink wrote:

Recent cross-project-dev traffic highlighted a decision to move to Java
6 only for aggregation builds.


it seems that Java 6 is preferred but other things may work.

Currently I develop with Java 5 with Java 5 compatibility. I presume
this is what other team members do too.

Should we move to:

Develop with Java 6, with Java 5 compatibility
Develop with Java 6, with Java 6 compatibility

Should we move now or after Indigo?

NB. Our current 5 + 5 gives us compatibility warnings with a JDT
reflective debug plugin.

I feel that if the platform expects perhaps only Java 6 to be ok, we
should be using Java 6 for development.



_______________________________________________ mailing list

_______________________________________________ mailing list

_______________________________________________ mailing list

Open Canarias, S.L.
	*Adolfo Sánchez-Barbudo Herrera*
C/Elías Ramos González, 4, ofc. 304
Tel.: +34 922 240231

_______________________________________________ mailing list

Back to the top