[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [mdt-bpmn2.dev] mdt-bpmn2.dev Digest, Vol 28, Issue 2

Thanks Reiner.



I'll read your article this week-end.


It's true like you say, I don't write the 'http://' in the XMI-Namespaces declaration. But is because I send the same question to other forums and I obtained an error that only overcome if I removed the 'http://'. After that I forgot to add again.
But with the correct file you include first, that's the same one I'd I get always the same error: 'Value of target Namespace not valid'.

Instead the simplified file you include in your answer works OK (now I've other errors but I think are related with the ATL transformations).



Moreover, we'd generated our XMI file (needed for the models in the ATL transformations), that I'd send in the previous e-mail, using the official xslt file to transform the BPMN20 files to XMI files (at http://www.omg.org/spec/BPMN/20100501/BPMN20-ToXMI.xslt).




In your answer, you ask to me, why I used my own ecore metamodel.
I use it, because I read in the ATL transfomations tutorials, that I need this format for the metamodels. And my ecore metamodel is the "official" implementation. It corresponds with a conversion (made in Eclipse) of the CMOF "official" bpmn2 spec (at http://www.omg.org/spec/BPMN/2.0/) to ecore.



Still grateful.



Paco.

On Thu, Sep 20, 2012 at 5:37 PM, <mdt-bpmn2.dev-request@xxxxxxxxxxx> wrote:
Send mdt-bpmn2.dev mailing list submissions to
        mdt-bpmn2.dev@xxxxxxxxxxx

To subscribe or unsubscribe via the World Wide Web, visit
        https://dev.eclipse.org/mailman/listinfo/mdt-bpmn2.dev
or, via email, send a message with subject or body 'help' to
        mdt-bpmn2.dev-request@xxxxxxxxxxx

You can reach the person managing the list at
        mdt-bpmn2.dev-owner@xxxxxxxxxxx

When replying, please edit your Subject line so it is more specific
than "Re: Contents of mdt-bpmn2.dev digest..."


Today's Topics:

   1. Problems with targetNamespace (paco gutierrez)
   2. Re: Problems with targetNamespace (Hille-Doering, Reiner)


----------------------------------------------------------------------

Message: 1
Date: Thu, 20 Sep 2012 15:43:42 +0200
From: paco gutierrez <pacogu998@xxxxxxxxx>
To: mdt-bpmn2.dev@xxxxxxxxxxx
Subject: [mdt-bpmn2.dev] Problems with targetNamespace
Message-ID:
        <CADWprfw-Ety3OaCBQz0ue04XgR34pWj-czqCv_OC52ZXG3=oMQ@xxxxxxxxxxxxxx>
Content-Type: text/plain; charset="iso-8859-1"

Hello,




I write you because I've a question I asked in the BPMN 2.0 Modeler Eclipse
Forum and they suggest me to put the question here.

I'm new in BPMN2, EMF and ATL and I begin working with ATL transformations
from BPMN 2.0 to other languages.
My metamodel is the file (.ecore) with the BPMN20 specifications of the
official site (http://www.omg.org/spec/BPMN/2.0/) and my model XMI file is:


<?xml version="1.0" encoding="UTF-8"?>
<xmi:XMI xmi:version="2.0" xmlns:bpmn="www.omg.org/spec/BPMN/20100524/MODEL"
xmlns:bpmnxmi="www.omg.org/spec/BPMN/20100524/MODEL-XMI" xmlns:dcxmi="
www.omg.org/spec/DD/20100524/DC-XMI" xmlns:bpmndi="
www.omg.org/spec/BPMN/20100524/DI" xmlns:dixmi="
www.omg.org/spec/DD/20100524/DI-XMI" xmlns:bpmndixmi="
www.omg.org/spec/BPMN/20100524/DI-XMI" xmlns:xmi="schema.omg.org/spec/XMI"
xmlns:di="www.omg.org/spec/DD/20100524/DI" xmlns:dc="
www.omg.org/spec/DD/20100524/DC">
<bpmnxmi:Definitions targetNamespace="www.brigid.net/bpmn20"
expressionLanguage="www.w3.org/1999/XPath" typeLanguage="
www.w3.org/2001/XMLSchema">
<rootElements xmi:type="bpmnxmi:Process" id="P1_sequence" name="P1 -
Sequence">
<flowElements xmi:type="bpmnxmi:EndEvent" id="end" name="End"
incoming="flow_C_end "/>
<flowElements xmi:type="bpmnxmi:SequenceFlow" id="flow_Start_A"
targetRef="action_A " sourceRef="start01 "/>
<flowElements xmi:type="bpmnxmi:SequenceFlow" id="flow_A_B"
targetRef="action_B " sourceRef="action_A "/>
<flowElements xmi:type="bpmnxmi:SequenceFlow" id="flow_B_C"
targetRef="action_C " sourceRef="action_B "/>
<flowElements xmi:type="bpmnxmi:SequenceFlow" id="flow_C_end"
targetRef="end " sourceRef="action_C "/>
<flowElements xmi:type="bpmnxmi:StartEvent" id="start01" name="Start"
outgoing="flow_Start_A "/>
<flowElements xmi:type="bpmnxmi:Task" id="action_A" name="Action A"
outgoing="flow_A_B " incoming="flow_Start_A "/>
<flowElements xmi:type="bpmnxmi:Task" id="action_B" name="Action B"
outgoing="flow_B_C " incoming="flow_A_B "/>
<flowElements xmi:type="bpmnxmi:Task" id="action_C" name="Action C"
outgoing="flow_C_end " incoming="flow_B_C "/>
<laneSets xmi:type="bpmnxmi:LaneSet" id="laneSet01" name="LaneSet01">
<lanes xmi:type="bpmnxmi:Lane" id="lane01" name="Lane01"
flowNodeRefs="flow_Start_A flow_A_B flow_B_C flow_C_end "/>
</laneSets>
</rootElements>
</bpmnxmi:Definitions>
</xmi:XMI>



I don't generate that model (.XMI) with BPMN they supply me like a part of
my project.
The XMI-model has not packages, then I don't need to register the
XMI-model? In fact, when I right-click in the file the option for that, no
appears.


I've problems when I run the transformations.
And I've the next error: "value of TargetNamespace is not legal".


I've send a topic to the ATL forum and they, first suggest me to open with
the Sample Reflective Ecore Model Editor to check
the validity of my XMI file. Then when I open with this editor I've get the
next error:
"org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package with uri '
www.omg.org/spec/BPMN/20100524/MODEL-XMI' not found."


After that, they suggest me to verify if my metamodel is loaded in the EMF
Registry.
For that, I've install a new version of Eclipse with Epsilon and Emfatic.
Then I've registered the metamodels I use:
bpmn20(www.omg.org/spec/BPMN/20100524/MODEL-XMI)
bpmndi(www.omg.org/spec/BPMN/20100524/DI-XMI)
dc(www.omg.org/spec/DD/20100524/DC-XMI)
di(www.omg.org/spec/DD/20100524/DI-XMI)

and I've get still the initial error when I open with the Sample Reflective
Ecore Model Editor: "value of TargetNamespace is not legal".

I've tested then, with other normally correct values (for targetNamespace)?:
"www.omg.org/bpmn20",
"www.omg.org/spec/BPMN/2.0/",
...

and I've always the same error, when I open with the Sample Reflective
Ecore Model Editor.


Anyone knows if there is a solution for the problem related with this issue
or if it's other the problem I have?
Pherhaps I have to register other metamodels?, or I have to install new
software in Eclipse, new XML, ATL packages, ...????
What registrations I need in order to read instances? Maybe I need a
specialized resource implementation as part of my project?




Could that be related with the issue (16398) in
www.omg.org/issues/bpmn2-rtf.open.html?:


Issue 16398: XML Schema not valid (bpmn2-rtf)

Nature: Clarification
Severity: Significant
Summary:
The official XML Schema for BPMN 2.0 (
www.omg.org/spec/BPMN/20100501/BPMN20.xsd) is not valid.

- It imports a schema with the schemaLocation "
www.omg.org/spec/BPMN/20100501/Diagram Interchange.xsd", which does not
exist.
Even when using the correct schemaLocation of "
www.omg.org/spec/BPMN/20100501/DI.xsd", the namespace does not match (
www.omg.com/di/1.0.0 vs. www.omg.org/spec/DD/20100524/DI)
(Note that one uses "omg.com" and the other uses "omg.org".)


- It includes the Schema "www.omg.org/spec/BPMN/20100501/Semantic.xsd", but
its targetNamespace www.omg.org/spec/BPMN/20100524/MODEL does not match the
including schema's value.



- The website www.omg.org/spec/BPMN/2.0/ has missmatching links for several
items:
-- "www.omg.org/spec/BPMN/20100501/DI.xsd" links to      "
www.omg.org/spec/BPMN/20100501/BPMNDI.xsd"
-- "www.omg.org/spec/BPMN/20100501/Semantic.xsd" links to "
www.omg.org/spec/BPMN/20100501/BPMNDI.xsd"


Resolution:
Revised Text:
Actions taken:
July 28, 2011: received issue



I've send a comment on this issue to bpmn2-rtf@xxxxxxx like it's suggested
in the site refered above, but no reply still.




Thanks in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://dev.eclipse.org/mailman/private/mdt-bpmn2.dev/attachments/20120920/0c47938d/attachment.html>

------------------------------

Message: 2
Date: Thu, 20 Sep 2012 17:36:46 +0200
From: "Hille-Doering, Reiner" <reiner.hille-doering@xxxxxxx>
To: BPMN2 Developers Mailing List <mdt-bpmn2.dev@xxxxxxxxxxx>
Subject: Re: [mdt-bpmn2.dev] Problems with targetNamespace
Message-ID:
        <5B1C15BD0D9C524DA056E4F85628F14760D90A7881@xxxxxxxxxxxxxxxxxxxxxxxx>
Content-Type: text/plain; charset="us-ascii"

Hi,
I'm not sure if you are aware of the fact that BPMN2 specified two official file formats: XML and XMI. For details, please read my article http://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/a0ec6d13-1ab4-2d10-dc87-c0a18d7f23c8 (and better also read the other 2 articles mentioned in http://wiki.eclipse.org/MDT-BPMN2 ).
You are using XMI, which is quite uncommon (most other tools only support XML).
Anyway, my ECore BPMN2 implementation (which is also used in the Eclipse BPMN2 modeler) supports both. However, if you want to try it, it is very important that you use the file extension ".xmi" (and not ".bpmn2"-which is used for XML files).
And of cause it is important to use the correct XML namespaces. "http://www.omg.org/spec/BPMN/20100524/MODEL" is the correct namespace for XML. For XMI (at least in my implementation), the correct namespace is "http://www.omg.org/spec/BPMN/20100524/MODEL-XMI" .
You file is almost correct, except that the XMI-Namespace declaration are missing the "http://"  and thus are considered not being correct. Here is the file that loads correctly into BPMN2 EMF model:
<?xml version="1.0" encoding="UTF-8"?>
<xmi:XMI xmi:version="2.0" xmlns:bpmn="www.omg.org/spec/BPMN/20100524/MODEL" xmlns:bpmnxmi="http://www.omg.org/spec/BPMN/20100524/MODEL-XMI" xmlns:dcxmi="www.omg.org/spec/DD/20100524/DC-XMI" xmlns:bpmndi="www.omg.org/spec/BPMN/20100524/DI" xmlns:dixmi="www.omg.org/spec/DD/20100524/DI-XMI" xmlns:bpmndixmi="www.omg.org/spec/BPMN/20100524/DI-XMI" xmlns:xmi="schema.omg.org/spec/XMI" xmlns:di="www.omg.org/spec/DD/20100524/DI" xmlns:dc="www.omg.org/spec/DD/20100524/DC">
<bpmnxmi:Definitions targetNamespace="www.brigid.net/bpmn20" expressionLanguage="www.w3.org/1999/XPath" typeLanguage="www.w3.org/2001/XMLSchema">
<rootElements xmi:type="bpmnxmi:Process" id="P1_sequence" name="P1 - Sequence">
<flowElements xmi:type="bpmnxmi:EndEvent" id="end" name="End" incoming="flow_C_end "/>
<flowElements xmi:type="bpmnxmi:SequenceFlow" id="flow_Start_A" targetRef="action_A " sourceRef="start01 "/>
<flowElements xmi:type="bpmnxmi:SequenceFlow" id="flow_A_B" targetRef="action_B " sourceRef="action_A "/>
<flowElements xmi:type="bpmnxmi:SequenceFlow" id="flow_B_C" targetRef="action_C " sourceRef="action_B "/>
<flowElements xmi:type="bpmnxmi:SequenceFlow" id="flow_C_end" targetRef="end " sourceRef="action_C "/>
<flowElements xmi:type="bpmnxmi:StartEvent" id="start01" name="Start" outgoing="flow_Start_A "/>
<flowElements xmi:type="bpmnxmi:Task" id="action_A" name="Action A" outgoing="flow_A_B " incoming="flow_Start_A "/>
<flowElements xmi:type="bpmnxmi:Task" id="action_B" name="Action B" outgoing="flow_B_C " incoming="flow_A_B "/>
<flowElements xmi:type="bpmnxmi:Task" id="action_C" name="Action C" outgoing="flow_C_end " incoming="flow_B_C "/>
<laneSets xmi:type="bpmnxmi:LaneSet" id="laneSet01" name="LaneSet01">
<lanes xmi:type="bpmnxmi:Lane" id="lane01" name="Lane01" flowNodeRefs="flow_Start_A flow_A_B flow_B_C flow_C_end "/>
</laneSets>
</rootElements>
</bpmnxmi:Definitions>
</xmi:XMI>

There are a couple of other issues with your file:

-          You don't need the XMLNS-declarations for the non-XMI versions, and correctly also not for DI/DD (as you don't use them).

-          The <lane ... flowNodeRefs="..." is not correct as SequenceFlows are no FlowNodes.

-          In XMI files that have a single root node (bpmnxmi:Definitions) you can skip the <xmi:XMI> element.

Here is the fixed result as it is stored from my BPMN2 Editor - still as valid XMI:
<?xml version="1.0" encoding="UTF-8"?>
<bpmn2:Definitions xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:bpmn2="http://www.omg.org/spec/BPMN/20100524/MODEL-XMI" expressionLanguage="www.w3.org/1999/XPath" targetNamespace="www.brigid.net/bpmn20" typeLanguage="www.w3.org/2001/XMLSchema">
  <rootElements xsi:type="bpmn2:Process" id="P1_sequence" name="P1 - Sequence">
    <laneSets id="laneSet01" name="LaneSet01">
      <lanes id="lane01" flowNodeRefs="end start01 action_A action_B action_C" name="Lane01"/>
    </laneSets>
    <flowElements xsi:type="bpmn2:EndEvent" id="end" name="End" incoming="flow_C_end"/>
    <flowElements xsi:type="bpmn2:SequenceFlow" id="flow_Start_A" sourceRef="start01" targetRef="action_A"/>
    <flowElements xsi:type="bpmn2:SequenceFlow" id="flow_A_B" sourceRef="action_A" targetRef="action_B"/>
    <flowElements xsi:type="bpmn2:SequenceFlow" id="flow_B_C" sourceRef="action_B" targetRef="action_C"/>
    <flowElements xsi:type="bpmn2:SequenceFlow" id="flow_C_end" sourceRef="action_C" targetRef="end"/>
    <flowElements xsi:type="bpmn2:StartEvent" id="start01" name="Start" outgoing="flow_Start_A"/>
    <flowElements xsi:type="bpmn2:Task" id="action_A" name="Action A" incoming="flow_Start_A" outgoing="flow_A_B"/>
    <flowElements xsi:type="bpmn2:Task" id="action_B" name="Action B" incoming="flow_A_B" outgoing="flow_B_C"/>
    <flowElements xsi:type="bpmn2:Task" id="action_C" name="Action C" incoming="flow_B_C" outgoing="flow_C_end"/>
  </rootElements>
</bpmn2:Definitions>

BTW: You write that you use your own ecore metamodel from the spec. Why? Couldn't you use our "official" implementation? Here a screenshot of you file in the BPMN2 Model Editor:
[cid:image002.png@xxxxxxxxxxxxxxxxx]

Best




From: mdt-bpmn2.dev-bounces@xxxxxxxxxxx [mailto:mdt-bpmn2.dev-bounces@xxxxxxxxxxx] On Behalf Of paco gutierrez
Sent: Donnerstag, 20. September 2012 15:44
To: mdt-bpmn2.dev@xxxxxxxxxxx
Subject: [mdt-bpmn2.dev] Problems with targetNamespace

Hello,




I write you because I've a question I asked in the BPMN 2.0 Modeler Eclipse Forum and they suggest me to put the question here.

I'm new in BPMN2, EMF and ATL and I begin working with ATL transformations from BPMN 2.0 to other languages.
My metamodel is the file (.ecore) with the BPMN20 specifications of the official site (http://www.omg.org/spec/BPMN/2.0/) and my model XMI file is:


<?xml version="1.0" encoding="UTF-8"?>
<xmi:XMI xmi:version="2.0" xmlns:bpmn="www.omg.org/spec/BPMN/20100524/MODEL<http://www.omg.org/spec/BPMN/20100524/MODEL>" xmlns:bpmnxmi="www.omg.org/spec/BPMN/20100524/MODEL-XMI<http://www.omg.org/spec/BPMN/20100524/MODEL-XMI>" xmlns:dcxmi="www.omg.org/spec/DD/20100524/DC-XMI<http://www.omg.org/spec/DD/20100524/DC-XMI>" xmlns:bpmndi="www.omg.org/spec/BPMN/20100524/DI<http://www.omg.org/spec/BPMN/20100524/DI>" xmlns:dixmi="www.omg.org/spec/DD/20100524/DI-XMI<http://www.omg.org/spec/DD/20100524/DI-XMI>" xmlns:bpmndixmi="www.omg.org/spec/BPMN/20100524/DI-XMI<http://www.omg.org/spec/BPMN/20100524/DI-XMI>" xmlns:xmi="schema.omg.org/spec/XMI<http://schema.omg.org/spec/XMI>" xmlns:di="www.omg.org/spec/DD/20100524/DI<http://www.omg.org/spec/DD/20100524/DI>" xmlns:dc="www.omg.org/spec/DD/20100524/DC<http://www.omg.org/spec/DD/20100524/DC>">
<bpmnxmi:Definitions targetNamespace="www.brigid.net/bpmn20<http://www.brigid.net/bpmn20>" expressionLanguage="www.w3.org/1999/XPath<http://www.w3.org/1999/XPath>" typeLanguage="www.w3.org/2001/XMLSchema<http://www.w3.org/2001/XMLSchema>">
<rootElements xmi:type="bpmnxmi:Process" id="P1_sequence" name="P1 - Sequence">
<flowElements xmi:type="bpmnxmi:EndEvent" id="end" name="End" incoming="flow_C_end "/>
<flowElements xmi:type="bpmnxmi:SequenceFlow" id="flow_Start_A" targetRef="action_A " sourceRef="start01 "/>
<flowElements xmi:type="bpmnxmi:SequenceFlow" id="flow_A_B" targetRef="action_B " sourceRef="action_A "/>
<flowElements xmi:type="bpmnxmi:SequenceFlow" id="flow_B_C" targetRef="action_C " sourceRef="action_B "/>
<flowElements xmi:type="bpmnxmi:SequenceFlow" id="flow_C_end" targetRef="end " sourceRef="action_C "/>
<flowElements xmi:type="bpmnxmi:StartEvent" id="start01" name="Start" outgoing="flow_Start_A "/>
<flowElements xmi:type="bpmnxmi:Task" id="action_A" name="Action A" outgoing="flow_A_B " incoming="flow_Start_A "/>
<flowElements xmi:type="bpmnxmi:Task" id="action_B" name="Action B" outgoing="flow_B_C " incoming="flow_A_B "/>
<flowElements xmi:type="bpmnxmi:Task" id="action_C" name="Action C" outgoing="flow_C_end " incoming="flow_B_C "/>
<laneSets xmi:type="bpmnxmi:LaneSet" id="laneSet01" name="LaneSet01">
<lanes xmi:type="bpmnxmi:Lane" id="lane01" name="Lane01" flowNodeRefs="flow_Start_A flow_A_B flow_B_C flow_C_end "/>
</laneSets>
</rootElements>
</bpmnxmi:Definitions>
</xmi:XMI>



I don't generate that model (.XMI) with BPMN they supply me like a part of my project.
The XMI-model has not packages, then I don't need to register the XMI-model? In fact, when I right-click in the file the option for that, no appears.


I've problems when I run the transformations.
And I've the next error: "value of TargetNamespace is not legal".


I've send a topic to the ATL forum and they, first suggest me to open with the Sample Reflective Ecore Model Editor to check
the validity of my XMI file. Then when I open with this editor I've get the next error:
"org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package with uri 'www.omg.org/spec/BPMN/20100524/MODEL-XMI<http://www.omg.org/spec/BPMN/20100524/MODEL-XMI>' not found."


After that, they suggest me to verify if my metamodel is loaded in the EMF Registry.
For that, I've install a new version of Eclipse with Epsilon and Emfatic.
Then I've registered the metamodels I use:
bpmn20(www.omg.org/spec/BPMN/20100524/MODEL-XMI<http://www.omg.org/spec/BPMN/20100524/MODEL-XMI>)
bpmndi(www.omg.org/spec/BPMN/20100524/DI-XMI<http://www.omg.org/spec/BPMN/20100524/DI-XMI>)
dc(www.omg.org/spec/DD/20100524/DC-XMI<http://www.omg.org/spec/DD/20100524/DC-XMI>)
di(www.omg.org/spec/DD/20100524/DI-XMI<http://www.omg.org/spec/DD/20100524/DI-XMI>)

and I've get still the initial error when I open with the Sample Reflective Ecore Model Editor: "value of TargetNamespace is not legal".

I've tested then, with other normally correct values (for targetNamespace)?:
"www.omg.org/bpmn20<http://www.omg.org/bpmn20>",
"www.omg.org/spec/BPMN/2.0/<http://www.omg.org/spec/BPMN/2.0/>",
...

and I've always the same error, when I open with the Sample Reflective Ecore Model Editor.


Anyone knows if there is a solution for the problem related with this issue or if it's other the problem I have?
Pherhaps I have to register other metamodels?, or I have to install new software in Eclipse, new XML, ATL packages, ...????
What registrations I need in order to read instances? Maybe I need a specialized resource implementation as part of my project?




Could that be related with the issue (16398) in www.omg.org/issues/bpmn2-rtf.open.html<http://www.omg.org/issues/bpmn2-rtf.open.html>?:


Issue 16398: XML Schema not valid (bpmn2-rtf)

Nature: Clarification
Severity: Significant
Summary:
The official XML Schema for BPMN 2.0 (www.omg.org/spec/BPMN/20100501/BPMN20.xsd<http://www.omg.org/spec/BPMN/20100501/BPMN20.xsd>) is not valid.

- It imports a schema with the schemaLocation "www.omg.org/spec/BPMN/20100501/Diagram<http://www.omg.org/spec/BPMN/20100501/Diagram> Interchange.xsd", which does not exist.
Even when using the correct schemaLocation of "www.omg.org/spec/BPMN/20100501/DI.xsd<http://www.omg.org/spec/BPMN/20100501/DI.xsd>", the namespace does not match (www.omg.com/di/1.0.0<http://www.omg.com/di/1.0.0> vs. www.omg.org/spec/DD/20100524/DI<http://www.omg.org/spec/DD/20100524/DI>)
(Note that one uses "omg.com<http://omg.com>" and the other uses "omg.org<http://omg.org>".)


- It includes the Schema "www.omg.org/spec/BPMN/20100501/Semantic.xsd<http://www.omg.org/spec/BPMN/20100501/Semantic.xsd>", but its targetNamespace www.omg.org/spec/BPMN/20100524/MODEL<http://www.omg.org/spec/BPMN/20100524/MODEL> does not match the including schema's value.



- The website www.omg.org/spec/BPMN/2.0/<http://www.omg.org/spec/BPMN/2.0/> has missmatching links for several items:
-- "www.omg.org/spec/BPMN/20100501/DI.xsd<http://www.omg.org/spec/BPMN/20100501/DI.xsd>" links to      "www.omg.org/spec/BPMN/20100501/BPMNDI.xsd<http://www.omg.org/spec/BPMN/20100501/BPMNDI.xsd>"
-- "www.omg.org/spec/BPMN/20100501/Semantic.xsd<http://www.omg.org/spec/BPMN/20100501/Semantic.xsd>" links to "      www.omg.org/spec/BPMN/20100501/BPMNDI.xsd<http://www.omg.org/spec/BPMN/20100501/BPMNDI.xsd>"


Resolution:
Revised Text:
Actions taken:
July 28, 2011: received issue



I've send a comment on this issue to bpmn2-rtf@xxxxxxx<mailto:bpmn2-rtf@xxxxxxx> like it's suggested in the site refered above, but no reply still.




Thanks in advance.







-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://dev.eclipse.org/mailman/private/mdt-bpmn2.dev/attachments/20120920/92ceaec5/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image002.png
Type: image/png
Size: 128110 bytes
Desc: image002.png
URL: <https://dev.eclipse.org/mailman/private/mdt-bpmn2.dev/attachments/20120920/92ceaec5/attachment.png>

------------------------------

_______________________________________________
mdt-bpmn2.dev mailing list
mdt-bpmn2.dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/mdt-bpmn2.dev


End of mdt-bpmn2.dev Digest, Vol 28, Issue 2
********************************************