[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [m2e-users] Installing m2e connector m2e-egit from catalog 1.6 fails

That URL also works for me, is there a proxy of some sort between you and maven central perhaps?



On 5 November 2015 at 10:42, Konrad Windszus <konrad_w@xxxxxx> wrote:
I get a 404 together with these response headers:

Accept-Ranges:bytes
Age:2946976
Connection:keep-alive
Content-Length:162
Content-Type:text/html
Date:Thu, 05 Nov 2015 15:39:27 GMT
Server:nginx
Via:1.1 varnish
Via:1.1 varnish
X-Cache:HIT, HIT
X-Cache-Hits:1, 52
X-Served-By:cache-iad2150-IAD, cache-fra1245-FRA
X-Timer:S1446737967.585196,VS0,VE0

When I get a 200 the response carries these headers:

Accept-Ranges: bytes
Age: 263018
Connection: keep-alive
Content-Length: 12122
Content-Type: application/java-archive
Date: Thu, 05 Nov 2015 15:40:38 GMT
Etag: "55ef9211-2f5a"
Last-Modified: Wed, 09 Sep 2015 01:57:37 GMT
Server: nginx
Via: 1.1 varnish, 1.1 varnish
X-Cache: HIT, HIT
X-Cache-Hits: 1, 25
X-Served-By: cache-iad2150-IAD, cache-fra1240-FRA
X-Timer: S1446738038.580375,VS0,VE0

> On 05 Nov 2015, at 16:37, Konrad Windszus <konrad_w@xxxxxx> wrote:
>
> Seem to work only in some cases. Probably some mirroring issue. Does http://uk.maven.org/maven2/.m2e/connectors/m2eclipse-egit/0.14.0/N/LATEST/plugins/org.sonatype.m2e.egit_0.14.0.201509090157.jar work for you reliably?
>
>> On 05 Nov 2015, at 16:27, Matthew Piggott <mpiggott@xxxxxxxxxxxx> wrote:
>>
>> Both URLs in your message appear to be the same, either way both lead to downloads for me.
>>
>> On 5 November 2015 at 10:23, Konrad Windszus <konrad_w@xxxxxx> wrote:
>>
>> When I try to install m2e-egit from the m2e catalog in version 1.6 (from within a plain Eclipse Mars SR1, Java Developer Edition) I get the following error:
>>
>> An error occurred while collecting items to be installed
>> session context was:(profile="" phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=""> >> Artifact not found: http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-egit/0.14.0/N/LATEST/plugins/org.sonatype.m2e.egit_0.14.0.201509090157.jar.
>> http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-egit/0.14.0/N/LATEST/plugins/org.sonatype.m2e.egit_0.14.0.201509090157.jar
>>
>> You can also see that although two artifacts are listed in http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-egit/0.14.0 only the former one can be downloaded, the latter (http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-egit/0.14.0/N/LATEST/plugins/org.sonatype.m2e.egit_0.14.0.201509090157.jar) leads to a 404!
>>
>> Thanks for any help,
>> Konrad
>> _______________________________________________
>> m2e-users mailing list
>> m2e-users@xxxxxxxxxxx
>> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
>> https://dev.eclipse.org/mailman/listinfo/m2e-users
>>
>> _______________________________________________
>> m2e-users mailing list
>> m2e-users@xxxxxxxxxxx
>> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
>> https://dev.eclipse.org/mailman/listinfo/m2e-users
>
> _______________________________________________
> m2e-users mailing list
> m2e-users@xxxxxxxxxxx
> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
> https://dev.eclipse.org/mailman/listinfo/m2e-users

_______________________________________________
m2e-users mailing list
m2e-users@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/m2e-users