[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[m2e-users] Custom javaagent JRE arguments

Hi,

I'm trying to use JMockit for my tests on an IBM J9 VM. However, when I launch my tests, I get the following error message:

java.lang.IllegalStateException: To run on IBM J9 VM, add <IBM SDK>/lib/tools.jar to the runtime classpath (before jmockit), or use -javaagent:C:\Users\Eric\.m2\repository\org\jmockit\jmockit\1.19\jmockit-1.19.jar


While I can do this for my own Eclipse configuration fairly easily (Preferences->JRE->Default VM Arguments), it becomes quite non-portable for others in the team when they import my MVN projects into their own IDE.

Is there someway to configure this in the POM to make it more portable?

I've updated the surefire-plugin options, but this doesn't seem to be pulled into the Eclipse project settings.

<!-- Configuration to use jmockit on IBM J9 -->
<plugin>
<artifactId>maven-surefire-plugin</artifactId>
<configuration>
<argLine>-javaagent:${org.jmockit:jmockit:jar}</argLine>
</configuration>
</plugin>


Thanks,

Eric