[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [jgit-dev] Proposed API breakage forcing us to JGit 2.0

On Mon, Feb 13, 2012 at 2:07 PM, Shawn Pearce <spearce@xxxxxxxxxxx> wrote:
> https://git.eclipse.org/r/5079 proposes an API change that will force
> the project to bump our major revision number.
>
> I can't really think of a sane way to avoid this. Given how few
> customers probably embed ReceivePack, or implement the interface in
> question, forcing customers to update their code may be cleaner than
> trying to maintain compatibility inside of JGit.

That's fine given that we are moving to 2.0 after shipping 1.3 soon.
We haven't really had the "2.0" discussion yet but this looks like to
be a good way to start it. There are probably other API breaking
changes we can do to simplify the code base. Since there are a lot
more JGit adopters now, we can try to inquire what people would like
to change.

-- 
Cheers,

Chris Aniszczyk
http://aniszczyk.org
+1 512 961 6719