Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [jgit-dev] JGit unit tests could be more readable.

On Thu, May 19, 2011 at 17:53, Ketan Padegaonkar
<ketanpadegaonkar@xxxxxxxxx> wrote:
> May I suggest that going ahead the tests be written in the form
> "testDoingSomethingShouldHaveThisSideEffect" or
> "testDoingSomethingShouldRaiseError". This ensures that reading the
> testname clearly conveys what is expected of the test.

I can't disagree with this.  :-)


I'll try harder in the future when writing test names.


Back to the top