Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [jetty-users] maven build of jetty9/git fails @ "Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin"?

The build requires Oracle Java JDK.  OpenJDK is not compatible with our build.

Runtime does not require Oracle Java JDK to execute Jetty.
However, if you decide you want to use http/2 then you are required to run Oracle Java (not openjdk) to get it to work.

These requirements go away when Java 9 is released.

Joakim Erdfelt <joakim@xxxxxxxxxxx>
Expert advice, services and support from from the Jetty & CometD experts

On Fri, Feb 27, 2015 at 10:50 AM, <h15234@xxxxxxxxxx> wrote:

On Fri, Feb 27, 2015, at 09:33 AM, Joakim Erdfelt wrote:
> 1.8.0_40, vendor: Oracle Corporation ??
> That's not available yet.

I'm not using oracle's java sdk.  I'm using opensuse's openjdk

which java
ls -al /usr/bin/java
 lrwxrwxrwx 1 root root 22 Feb  2  2013 /usr/bin/java -> /etc/alternatives/java*
ls -al /etc/alternatives/java
 lrwxrwxrwx 1 root root 48 Feb 26 14:46 /etc/alternatives/java -> /usr/lib64/jvm/java-1.8.0-openjdk-1.8.0/bin/java*
rpm -q --whatprovides /usr/lib64/jvm/java-1.8.0-openjdk-1.8.0/bin/java

It's what my distro, Opensuse 13.2, provides as its "official release" here:

> Our build has NPN/ALPN dependencies that require bootclasspath
> modifications of the SslEngine.
> Those modifications are JVM specific, and there is no JVM specific version
> for 1.8.0_40 (yet).
> Downgrade to 1.8.0_31 and try again.

1.8.0_31 isn't available from Opensuse

> Note: NPN has been dropped in Jetty 9.3.x so that's one less problem on
> that version of Jetty.

Isn't that already the case in git-head from


> And when Java 9 comes out with its expected support for ALPN, then our
> bootclasspath requirement will go away for that JVM.

I'll do some more reading an ALPN.



Back to the top