|[jdt-dev] Improvement of a JDT plugin|
My name is Maxime Maurin and I am currently on an internship at ALL4TEC, in France. My objective is to improve the development tools used by the company so they can adapt to their needs. One of their requests was to improve a feature of Eclipse. It is currently possible to generate Javadoc comments for functions (such as getters and setters). It is possible, using templates, to use variables to display the name of the function, the type of parameters or even their name.
The company All4TEC wanted to add a new variable to display the name of the variable related to the setter by separating each word by a space. The name of the variable being written in camelCase format, it was preferable for the company's projects to generate comments with the name of the variable much more readable. I imported the Eclipse project (org.eclipse.jdt in this case) and made some modifications to make it possible.
I am sure other people will be interested by this feature, but I currently don’t know how to contribute to the project easily. Maybe one of you, as official contributor, can integrate it in the main Git repository ?
Thank you for taking the time to read me.
Back to the top