[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [ide-dev] Being a nice citizen and installing Oxygen M7 -- but installation is so painful

Did you try the new (Oomph) installer?

Dani



From:        Michael Scharf <eclipse@xxxxxxxxx>
To:        Discussions about the IDE <ide-dev@xxxxxxxxxxx>
Date:        14.05.2017 20:50
Subject:        Re: [ide-dev] Being a nice citizen and installing Oxygen M7 -- but installation is so painful
Sent by:        ide-dev-bounces@xxxxxxxxxxx




Hi Mikael,

> On Sat, May 13, 2017 at 1:17 AM, Michael Scharf <eclipse@xxxxxxxxx <
mailto:eclipse@xxxxxxxxx>> wrote:
>
>     I wanted to install Oxygen M7 to test it and report problems
>     (if I find any) before it goes GA.
>
>
> That's kind but it's a bit too early to Beta-Test Oxygen M7. Only Platform did publish its M7 contribution AFAIK and no other simultaneous project did yet, so the simultaneous release and EPP Oxygen M7 builds aren't done yet, so it's too
> early for you to Beta-Test Eclipse IDE Oxygen M7 (unless you feel like a Platform contributor in which case you should ask that on Eclipse Platform mailing-list).

OOPS! I thought M7 was officially out! I misunderstood the announcement on
> [eclipse-dev] Oxygen (4.7) M7 is available

The availability of the `New and Noteworthy` link
 
http://www.eclipse.org/eclipse/news/4.7/M7/
was an indication for me that M7 is available. But I was obviously wrong...


Michael

>     Eclipse Installs
>     ================
>
>     Now if I contrast this to eclipse, upgrading is sooooooo painful.
>     I have an Oxigen M6 running. Now I want to upgrade:
>
>
> I believe the pain comes from that fact that you're trying to test something (Eclipse IDE Oxygen M7) that is not ready to be tested.
> If you simply wait for SimRel and EPP M7 to be published, "Check for Updates" should work.
>  
>
>     And now comes the painful part -- I have installed a few packages, but I don't
>     remember what I have installed and how I installed it.
>
>
> You can use the Marketplace Favourites list to "persist" a list of things to install in case you restart from a Fresh Install. The Marketplace client now allows you to install all those favorite features at once.
>
>     - I exported the packages that I think I have installed manually
>     - with the M7 I saw in the import there is a way to install it form an
>       existing installation. I decided to import "Form existing installation"
>     - that worked better than expected
>
>
> It's been there for more than 5 years IIRC ;)
>  
>
>     - now the question: where do I find the eclipse marketplace client???
>
>
> You installed the SDK, it's not the Eclipse IDE, it's missing a lot of things for end-users...
>  
>
>     [...]
>
>
> All the issues you got come from the fact that you tried to update to a version that's not available yet, and decided to go forward anyway by finding workarounds to build an IDE based on Platform M7. As mentioned above, if you just wait for
> M7 to be available, Check for Updates from M6 should work, and if automated updates are turned on (and they usually are), you'd be notified that an update is available whenever it's ready.
>
> HTH,
> Mickael
>
> PS: By the way, I used your comment as a motivation to add an entry to the "Upgrade" wiki page:
https://wiki.eclipse.org/FAQ_How_do_I_upgrade_Eclipse_IDE%3F#Beta-testing_milestones_and_release_candidates, thanks!


_______________________________________________
ide-dev mailing list
ide-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/ide-dev