Re: [handly-dev] A better naming convention for model *Impl* interface methods?
Thank you for the quick response, and the warning about the naming guidelines! I have not thought about this issue of potential clashing with code generators. I also don't know if this would have any practical importance in this case. I'll try to do more research on that.
To make your opinion a bit more clear to me -- speaking strictly stylistically, do you mean "no problem" with the existing convention, the proposed one, or both? Is there any preference? :-)
I don't have a problem with that. The naming guidelines say that identifiers should not start with $ and _ (although it is allowed), presumably so that code generators can be reasonably certain that they don't introduce name clashes. I don't know if this would have any practical importance, or it is just a style issue.